diff --git a/Makefile b/Makefile
index 2a78178..3b2780a 100644
--- a/Makefile
+++ b/Makefile
@@ -3,6 +3,8 @@ REDIS_RB_VENDOR_DIR=lib/vendor/redis
 PWD=`pwd`
 
 all:
+	bin/compile
+	strip -s bin/gitaly-*
 
 update-redis:
 	rm -rf $(REDIS_RB_VENDOR_DIR)