You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

package.json 2.0KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. {
  2. "name": "convertorizr",
  3. "version": "1.3.1-1",
  4. "description": "Decode or encode base64, punycode, HTML entities, URI components, ...",
  5. "keywords": [
  6. "encode",
  7. "decode",
  8. "conversion",
  9. "converter",
  10. "convert"
  11. ],
  12. "author": {
  13. "name": "Manuel Friedli",
  14. "email": "manuel@fritteli.ch"
  15. },
  16. "license": "MIT",
  17. "homepage": "https://manuel.pages.gittr.ch/dencode.org",
  18. "repository": {
  19. "type": "git",
  20. "url": "https://gittr.ch/manuel/converter.git"
  21. },
  22. "scripts": {
  23. "ng": "ng",
  24. "start": "ng serve",
  25. "build": "ng build --delete-output-path",
  26. "build-prod": "ng build --prod --optimization --aot --delete-output-path --build-optimizer",
  27. "test": "ng test --code-coverage",
  28. "test:ci": "ng test --browsers ChromeHeadlessNoSandbox --watch=false --code-coverage",
  29. "lint": "ng lint",
  30. "e2e": "ng e2e",
  31. "postinstall": "npm rebuild node-sass"
  32. },
  33. "private": true,
  34. "dependencies": {
  35. "@angular/common": "6.1.7",
  36. "@angular/compiler": "6.1.7",
  37. "@angular/core": "6.1.7",
  38. "@angular/forms": "6.1.7",
  39. "@angular/platform-browser": "6.1.7",
  40. "@angular/platform-browser-dynamic": "6.1.7",
  41. "@angular/router": "6.1.7",
  42. "core-js": "^2.5.1",
  43. "punycode": "^2.1.0",
  44. "quoted-printable": "^1.0.0",
  45. "rxjs": "^6.3.2",
  46. "utf8": "^2.1.0",
  47. "zone.js": "^0.8.26"
  48. },
  49. "devDependencies": {
  50. "@angular-devkit/build-angular": "~0.7.0",
  51. "@angular/cli": "6.1.5",
  52. "@angular/compiler-cli": "6.1.7",
  53. "@types/jasmine": "~2.8.6",
  54. "@types/jasminewd2": "~2.0.3",
  55. "@types/node": "~8.9.4",
  56. "codelyzer": "~4.2.1",
  57. "jasmine-core": "~2.99.1",
  58. "jasmine-spec-reporter": "~4.2.1",
  59. "karma": "~1.7.1",
  60. "karma-chrome-launcher": "~2.2.0",
  61. "karma-coverage-istanbul-reporter": "~2.0.0",
  62. "karma-jasmine": "~1.1.1",
  63. "karma-jasmine-html-reporter": "^0.2.2",
  64. "karma-nightmare": "~0.4.15",
  65. "protractor": "~5.4.0",
  66. "puppeteer": "~1.7.0",
  67. "ts-node": "~5.0.1",
  68. "tslint": "~5.9.1",
  69. "typescript": "2.9.2"
  70. }
  71. }