don't make the ati-ebuild stable; also, added all files

This commit is contained in:
Manuel Friedli 2008-08-22 10:33:30 +00:00
parent 7ce4efabfe
commit 0f8608fbea
21 changed files with 706 additions and 2 deletions

View File

@ -1,2 +1,2 @@
DIST ati-driver-installer-8-8-x86.x86_64.run 63976178 RMD160 ce6541c1577dbf6d296c5a86525fe56172b6d495 SHA1 32981bb142b8fa061b491ca8b41497981e70bcb1 SHA256 4c38f2a074fbdddbfd76f0bd5c83db282229e5a8905fab38526b91506ec0846d
EBUILD ati-drivers-8.502.ebuild 14673 RMD160 ee99c460c3dd477976da55ea959aae4b55808df1 SHA1 d0532919509d877455bd95c2834a339722346c1b SHA256 40a102447fcb704e4312bb5bcf38ed8a7f5b31b7526613b7bdfe6becc8fa4991
EBUILD ati-drivers-8.502.ebuild 14674 RMD160 17e81013c4ae17b42c89e294c3b0ff0054b07a78 SHA1 dddbe1c11425d4fb078a385800353b3316ed9977 SHA256 fd2695893d2c547fed6226393dc3a1e0f31e80d4346c63688f13aff5e4d051f1

View File

@ -12,7 +12,7 @@ ATI_URL="https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/"
SRC_URI="${ATI_URL}/ati-driver-installer-8-8-x86.x86_64.run"
LICENSE="AMD GPL-2 QPL-1.0 as-is"
KEYWORDS="~amd64 x86"
KEYWORDS="~amd64 ~x86"
# The portage dep is for COLON_SEPARATED support in env-update.
# The eselect dep (>=1.0.9) is for COLON_SEPARATED in eselect env update.

View File

@ -0,0 +1,3 @@
PATH=/opt/ati/bin
ROOTPATH=/opt/ati/bin:/opt/ati/sbin
MANPATH=/opt/ati/man

View File

@ -0,0 +1,17 @@
--- common-orig/lib/modules/fglrx/build_mod/firegl_public.c 2007-08-01 16:58:40.000000000 -0500
+++ common/lib/modules/fglrx/build_mod/firegl_public.c 2007-08-01 16:57:11.000000000 -0500
@@ -144,12 +144,14 @@
#define EXPORT_NO_SYMBOLS
#endif
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,22)
#ifdef __x86_64__
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,12)
#include "linux/ioctl32.h"
#else
#include "asm/ioctl32.h"
#endif
+#endif
#ifdef __x86_64__
#include "asm/compat.h"

View File

@ -0,0 +1,41 @@
diff -Naur common/lib/modules/fglrx/build_mod/firegl_public.c common/lib/modules/fglrx/build_mod/firegl_public.c
--- common/lib/modules/fglrx/build_mod/firegl_public.c 2007-07-29 13:36:37.000000000 +0200
+++ common/lib/modules/fglrx/build_mod/firegl_public.c 2007-07-29 14:24:11.000000000 +0200
@@ -2409,7 +2409,11 @@
#ifdef pte_offset_map
pte_p = pte_offset_map(pmd_p, virtual_addr);
if (pte_present(*pte_p))
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,22)
ret = (ptep_clear_flush_dirty(vma, virtual_addr, pte_p) ? 1 : 0);
+#else
+ return 0;
+#endif
else
__KE_DEBUG("page not exists!\n");
pte_unmap(pte_p);
@@ -3399,9 +3403,11 @@
sprintf(buf, "0x%Lx %c%c%c%c%c%c\n",
*phys_address,
pte_present (pte) ? 'p' : '-',
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,23)
pte_read (pte) ? 'r' : '-',
- pte_write (pte) ? 'w' : '-',
pte_exec (pte) ? 'x' : '-',
+#endif
+ pte_write (pte) ? 'w' : '-',
pte_dirty (pte) ? 'd' : '-',
pte_young (pte) ? 'a' : '-');
}
@@ -5348,7 +5354,11 @@
DBG_TRACE("creating slab object '%s'", slabcache_obj->name);
if ((slabcache_obj->cache =
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,23)
kmem_cache_create(slabcache_obj->name, iEntrySize, 0, 0, NULL, NULL)))
+#else
+ kmem_cache_create(slabcache_obj->name, iEntrySize, 0, 0, NULL)))
+#endif
{
ret = 1;
}

View File

@ -0,0 +1,90 @@
diff -Naur common/lib/modules/fglrx/build_mod/firegl_public.c common/lib/modules/fglrx/build_mod/firegl_public.c
--- common/lib/modules/fglrx/build_mod/firegl_public.c 2007-07-29 13:36:37.000000000 +0200
+++ common/lib/modules/fglrx/build_mod/firegl_public.c 2007-07-29 14:24:11.000000000 +0200
@@ -452,7 +452,7 @@
}
static unsigned int
-firegl_interrupt_poll_wrap(struct file *user_file, poll_table *pt)
+firegl_interrupt_poll_wrap(struct file *user_file, struct poll_table_struct *pt)
{
if(firegl_interrupt_poll(user_file, (__ke_poll_table*)pt))
{
@@ -1491,7 +1491,8 @@
int ATI_API_CALL firegl_put_user_ptr(void *src, u32 *dst)
{
void *temp = src;
- return put_user(temp, dst);
+ void *dst_temp = dst;
+ return put_user(temp, dst_temp);
}
int ATI_API_CALL firegl_put_user_u16(u16 src, u16 *dst)
@@ -1883,7 +1884,7 @@
__ke_pci_dev_t* ATI_API_CALL __ke_pci_find_device (unsigned int vendor, unsigned int dev, __ke_pci_dev_t* from)
{
- return (__ke_pci_dev_t*)pci_find_device( vendor, dev, (struct pci_dev *)(void *)from );
+ return (__ke_pci_dev_t*) pci_get_device(vendor, dev, (struct pci_dev *)(void *) from);
}
void* ATI_API_CALL __ke_malloc(__ke_size_t size)
@@ -2813,9 +2814,9 @@
#else
static void ATI_API_CALL (*irq_handler_func)(int, void*, void*); /* function pointer variable */
-static irqreturn_t ke_irq_handler_wrap(int irq, void *arg1, struct pt_regs *regs)
+static irqreturn_t ke_irq_handler_wrap(int irq, void *arg1)
{
- irq_handler_func(irq, arg1, regs);
+ irq_handler_func(irq, arg1, NULL);
return IRQ_HANDLED;
}
@@ -2826,7 +2827,7 @@
irq_handler_func = handler;
return request_irq(irq,
ke_irq_handler_wrap,
- SA_SHIRQ, dev_name, dev_id);
+ IRQF_SHARED, dev_name, dev_id);
}
void ATI_API_CALL __ke_free_irq(unsigned int irq, void *dev_id)
@@ -2848,9 +2849,7 @@
void ATI_API_CALL __ke_unregister_ioctl32_conversion(unsigned int cmd)
{
-#ifdef FIREGL_IOCTL_COMPAT
- return 0;
-#else
+#ifndef FIREGL_IOCTL_COMPAT
unregister_ioctl32_conversion(cmd);
#endif
}
@@ -4353,7 +4352,7 @@
void ATI_API_CALL KCL_CallFuncOnOtherCpus(firegl_void_routine_t func_to_call)
{
#ifdef CONFIG_SMP
- smp_call_function( firegl_smp_func_parameter_wrap, (void*)func_to_call, 0, 1 );
+ smp_call_function( (void (*)(void *info)) func_to_call, NULL, 0, 1 );
#endif
}
@@ -5303,7 +5302,7 @@
/** \brief Type definition of the structure describing Slab Cache object */
typedef struct tag_kasSlabCache_t
{
- kmem_cache_t* cache; /* OS slab cache object */
+ struct kmem_cache* cache; /* OS slab cache object */
spinlock_t lock; /* OS spinlock object protecting the cache */
unsigned int routine_type; /* Type of routine the cache might be accessed from */
char name[14]; /* Cache object name (kernel 2.4 restricts its length to 19 chars) */
@@ -5344,7 +5343,7 @@
slabcache_obj->routine_type = access_type;
spin_lock_init(&(slabcache_obj->lock));
- sprintf(slabcache_obj->name, "kas(%08X)", (unsigned int)slabcache_obj);
+ sprintf(slabcache_obj->name, "kas(%08X)", (unsigned int)(long unsigned int)slabcache_obj);
DBG_TRACE("creating slab object '%s'", slabcache_obj->name);

View File

@ -0,0 +1,33 @@
diff -ur common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh
--- common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-07-28 04:22:36.000000000 +0100
+++ common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-08-04 12:19:42.000000000 +0100
@@ -17,6 +17,10 @@
fi
}
+aticonfig='/opt/bin/aticonfig'
+
+# default high power state
+default_state=`$aticonfig --lsp | grep 'default state' | cut -c 3`
grep -q closed /proc/acpi/button/lid/*/state
if [ $? = 0 ]; then
@@ -46,7 +50,7 @@
getXuser;
if [ x"$XAUTHORITY" != x"" ]; then
export DISPLAY=":$displaynum"
- su $user -c "/usr/X11R6/bin/aticonfig --set-powerstate=1 --effective=now"
+ su $user -c "$aticonfig --set-powerstate=1 --effective=now"
fi
done
else
@@ -56,7 +60,7 @@
getXuser;
if [ x"$XAUTHORITY" != x"" ]; then
export DISPLAY=":$displaynum"
- su $user -c "/usr/X11R6/bin/aticonfig --set-powerstate=3 --effective=now"
+ su $user -c "$aticonfig --set-powerstate=$default_state --effective=now"
fi
done
fi

View File

@ -0,0 +1,40 @@
--- common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh-orig 2007-12-23 22:48:55.873089378 -0600
+++ common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2007-12-23 22:49:59.246421379 -0600
@@ -4,6 +4,8 @@
# Control script for ACPI lid state and AC adapter state
#
+aticonfig='/opt/bin/aticonfig'
+
getXuser() {
user=`who| grep -m1 ":$displaynum " | awk '{print $1}'`
if [ x"$user" = x"" ]; then
@@ -47,7 +49,7 @@
done
#If PPLIB is enabled
-su $user -c '/usr/bin/aticonfig --pplib-cmd="get version"' | grep PPLIB
+su $user -c '$aticonfig --pplib-cmd="get version"' | grep PPLIB
if [ $? = 0 ]; then
echo "Has PPLIB"
has_pplib=1
@@ -61,15 +63,15 @@
if [ ${lid_closed} -eq 1 -o ${on_dc} -eq 1 ]; then
echo "Low power"
if [ ${has_pplib} -eq 1 ]; then
- su $user -c '/usr/bin/aticonfig --pplib-cmd="notify psrc dc"'
+ su $user -c '$aticonfig --pplib-cmd="notify psrc dc"'
else
- su $user -c "/usr/bin/aticonfig --set-powerstate=1 --effective=now"
+ su $user -c "$aticonfig --set-powerstate=1"
fi
else
echo "high power"
if [ ${has_pplib} -eq 1 ]; then
- su $user -c '/usr/bin/aticonfig --pplib-cmd="notify psrc ac"'
+ su $user -c '$aticonfig --pplib-cmd="notify psrc ac"'
else
- su $user -c "/usr/bin/aticonfig --set-powerstate=3 --effective=now"
+ su $user -c "$aticonfig --set-powerstate=$($aticonfig --lsp | grep 'default state' | cut -c 3)"
fi
fi

View File

@ -0,0 +1,42 @@
diff -ur common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh
--- common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-07-28 04:22:36.000000000 +0100
+++ common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-08-04 12:19:42.000000000 +0100
@@ -4,6 +4,8 @@
# Control script for ACPI lid state and AC adapter state
#
+aticonfig='/opt/bin/aticonfig'
+
getXuser() {
user=`finger| grep -m1 ":$displaynum " | awk '{print $1}'`
if [ x"$user" = x"" ]; then
@@ -47,7 +49,7 @@
done
#If PPLIB is enabled
-su $user -c '/usr/bin/aticonfig --pplib-cmd="get version"' | grep PPLIB
+su $user -c '$aticonfig --pplib-cmd="get version"' | grep PPLIB
if [ $? = 0 ]; then
echo "Has PPLIB"
has_pplib=1
@@ -61,15 +63,15 @@
if [ ${lid_closed} -eq 1 -o ${on_dc} -eq 1 ]; then
echo "Low power"
if [ ${has_pplib} -eq 1 ]; then
- su $user -c '/usr/bin/aticonfig --pplib-cmd="notify psrc dc"'
+ su $user -c '$aticonfig --pplib-cmd="notify psrc dc"'
else
- su $user -c "/usr/bin/aticonfig --set-powerstate=1 --effective=now"
+ su $user -c "$aticonfig --set-powerstate=1"
fi
else
echo "high power"
if [ ${has_pplib} -eq 1 ]; then
- su $user -c '/usr/bin/aticonfig --pplib-cmd="notify psrc ac"'
+ su $user -c '$aticonfig --pplib-cmd="notify psrc ac"'
else
- su $user -c "/usr/bin/aticonfig --set-powerstate=3 --effective=now"
+ su $user -c "$aticonfig --set-powerstate=$($aticonfig --lsp | grep 'default state' | cut -c 3)"
fi
fi

View File

@ -0,0 +1,42 @@
diff -ur common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh
--- common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-07-28 04:22:36.000000000 +0100
+++ common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-08-04 12:19:42.000000000 +0100
@@ -4,6 +4,8 @@
# Control script for ACPI lid state and AC adapter state
#
+aticonfig='/opt/bin/aticonfig'
+
getXuser() {
user=`finger| grep -m1 ":$displaynum " | awk '{print $1}'`
if [ x"$user" = x"" ]; then
@@ -47,7 +49,7 @@
done
#If PPLIB is enabled
-su $user -c '/usr/bin/aticonfig --pplib-cmd="get version"' | grep PPLIB
+su $user -c '$aticonfig --pplib-cmd="get version"' | grep PPLIB
if [ $? = 0 ]; then
echo "Has PPLIB"
has_pplib=1
@@ -61,15 +63,15 @@
if [ ${lid_closed} -eq 1 -o ${on_dc} -eq 1 ]; then
echo "Low power"
if [ ${has_pplib} -eq 1 ]; then
- su $user -c '/usr/bin/aticonfig --pplib-cmd="notify psrc dc"'
+ su $user -c '$aticonfig --pplib-cmd="notify psrc dc"'
else
- su $user -c "/usr/bin/aticonfig --set-powerstate=1 --effective=now"
+ su $user -c "$aticonfig --set-powerstate=1"
fi
else
echo "high power"
if [ ${has_pplib} -eq 1 ]; then
- su $user -c '/usr/bin/aticonfig --pplib-cmd="notify psrc ac"'
+ su $user -c '$aticonfig --pplib-cmd="notify psrc ac"'
else
- su $user -c "/usr/bin/aticonfig --set-powerstate=3 --effective=now"
+ su $user -c "$aticonfig --set-powerstate=$($aticonfig --lsp | grep 'default state' | cut -c 3)"
fi
fi

View File

@ -0,0 +1,42 @@
diff -ur common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh
--- common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-07-28 04:22:36.000000000 +0100
+++ common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-08-04 12:19:42.000000000 +0100
@@ -4,6 +4,8 @@
# Control script for ACPI lid state and AC adapter state
#
+aticonfig='/opt/bin/aticonfig'
+
getXuser() {
user=`finger| grep -m1 ":$displaynum " | awk '{print $1}'`
if [ x"$user" = x"" ]; then
@@ -47,7 +49,7 @@
done
#If PPLIB is enabled
-su $user -c '/usr/bin/aticonfig --pplib-cmd="get version"' | grep PPLIB
+su $user -c '$aticonfig --pplib-cmd="get version"' | grep PPLIB
if [ $? = 0 ]; then
echo "Has PPLIB"
has_pplib=1
@@ -61,15 +63,15 @@
if [ ${lid_closed} -eq 1 -o ${on_dc} -eq 1 ]; then
echo "Low power"
if [ ${has_pplib} -eq 1 ]; then
- su $user -c '/usr/bin/aticonfig --pplib-cmd="notify psrc dc"'
+ su $user -c '$aticonfig --pplib-cmd="notify psrc dc"'
else
- su $user -c "/usr/bin/aticonfig --set-powerstate=1 --effective=now"
+ su $user -c "$aticonfig --set-powerstate=1"
fi
else
echo "high power"
if [ ${has_pplib} -eq 1 ]; then
- su $user -c '/usr/bin/aticonfig --pplib-cmd="notify psrc ac"'
+ su $user -c '$aticonfig --pplib-cmd="notify psrc ac"'
else
- su $user -c "/usr/bin/aticonfig --set-powerstate=3 --effective=now"
+ su $user -c "$aticonfig --set-powerstate=$($aticonfig --lsp | grep 'default state' | cut -c 3)"
fi
fi

View File

@ -0,0 +1,42 @@
diff -ur common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh
--- common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-07-28 04:22:36.000000000 +0100
+++ common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-08-04 12:19:42.000000000 +0100
@@ -4,6 +4,8 @@
# Control script for ACPI lid state and AC adapter state
#
+aticonfig='/opt/bin/aticonfig'
+
getXuser() {
user=`finger| grep -m1 ":$displaynum " | awk '{print $1}'`
if [ x"$user" = x"" ]; then
@@ -47,7 +49,7 @@
done
#If PPLIB is enabled
-su $user -c '/usr/bin/aticonfig --pplib-cmd="get version"' | grep PPLIB
+su $user -c '$aticonfig --pplib-cmd="get version"' | grep PPLIB
if [ $? = 0 ]; then
echo "Has PPLIB"
has_pplib=1
@@ -61,15 +63,15 @@
if [ ${lid_closed} -eq 1 -o ${on_dc} -eq 1 ]; then
echo "Low power"
if [ ${has_pplib} -eq 1 ]; then
- su $user -c '/usr/bin/aticonfig --pplib-cmd="notify psrc dc"'
+ su $user -c '$aticonfig --pplib-cmd="notify psrc dc"'
else
- su $user -c "/usr/bin/aticonfig --set-powerstate=1 --effective=now"
+ su $user -c "$aticonfig --set-powerstate=1"
fi
else
echo "high power"
if [ ${has_pplib} -eq 1 ]; then
- su $user -c '/usr/bin/aticonfig --pplib-cmd="notify psrc ac"'
+ su $user -c '$aticonfig --pplib-cmd="notify psrc ac"'
else
- su $user -c "/usr/bin/aticonfig --set-powerstate=3 --effective=now"
+ su $user -c "$aticonfig --set-powerstate=$($aticonfig --lsp | grep 'default state' | cut -c 3)"
fi
fi

View File

@ -0,0 +1,67 @@
diff -urN fglrx-install-old/common/lib/modules/fglrx/build_mod/agp3.c fglrx-install/common/lib/modules/fglrx/build_mod/agp3.c
--- fglrx-install-old/common/lib/modules/fglrx/build_mod/agp3.c 2006-09-19 19:30:42.000000000 -0500
+++ fglrx-install/common/lib/modules/fglrx/build_mod/agp3.c 2006-10-27 09:44:23.902749464 -0500
@@ -61,7 +61,6 @@
#include <linux/modversions.h>
#endif
#endif
-#include <linux/config.h>
#include <linux/module.h>
#include <linux/pci.h>
#include <linux/init.h>
diff -urN fglrx-install-old/common/lib/modules/fglrx/build_mod/agpgart_be.c fglrx-install/common/lib/modules/fglrx/build_mod/agpgart_be.c
--- fglrx-install-old/common/lib/modules/fglrx/build_mod/agpgart_be.c 2006-09-19 19:30:42.000000000 -0500
+++ fglrx-install/common/lib/modules/fglrx/build_mod/agpgart_be.c 2006-10-27 09:44:34.265174136 -0500
@@ -99,9 +99,6 @@
#endif
#endif
-#include <linux/config.h>
-
-
#include <linux/module.h>
#include <linux/types.h>
#include <linux/kernel.h>
diff -urN fglrx-install-old/common/lib/modules/fglrx/build_mod/drm.h fglrx-install/common/lib/modules/fglrx/build_mod/drm.h
--- fglrx-install-old/common/lib/modules/fglrx/build_mod/drm.h 2006-09-19 19:30:42.000000000 -0500
+++ fglrx-install/common/lib/modules/fglrx/build_mod/drm.h 2006-10-27 09:44:52.502401656 -0500
@@ -38,7 +38,6 @@
#define _DRM_H_
#if defined(__linux__)
-#include <linux/config.h>
#include <asm/ioctl.h> /* For _IO* macros */
#define DRM_IOCTL_NR(n) _IOC_NR(n)
#define DRM_IOC_VOID _IOC_NONE
diff -urN fglrx-install-old/common/lib/modules/fglrx/build_mod/drmP.h fglrx-install/common/lib/modules/fglrx/build_mod/drmP.h
--- fglrx-install-old/common/lib/modules/fglrx/build_mod/drmP.h 2006-09-19 19:30:42.000000000 -0500
+++ fglrx-install/common/lib/modules/fglrx/build_mod/drmP.h 2006-10-27 09:45:03.912667032 -0500
@@ -42,7 +42,6 @@
* can build the DRM (part of PI DRI). 4/21/2000 S + B */
#include <asm/current.h>
#endif /* __alpha__ */
-#include <linux/config.h>
#include <linux/module.h>
#include <linux/kernel.h>
#include <linux/miscdevice.h>
diff -urN fglrx-install-old/common/lib/modules/fglrx/build_mod/firegl_public.c fglrx-install/common/lib/modules/fglrx/build_mod/firegl_public.c
--- fglrx-install-old/common/lib/modules/fglrx/build_mod/firegl_public.c 2006-09-19 19:30:42.000000000 -0500
+++ fglrx-install/common/lib/modules/fglrx/build_mod/firegl_public.c 2006-10-27 09:45:47.463046368 -0500
@@ -67,9 +67,6 @@
* for example for CPU hot-plugging. I wonder why a desktop
* distribution would even include such a kernel patch. */
#ifdef CONFIG_MEM_MIRROR
-/* Prevent linux/config.h from being included again in subsequent
- * kernel headers as that would redefine CONFIG_MEM_MIRROR. */
-#include <linux/config.h>
#warning "Disabling CONFIG_MEM_MIRROR because it does not work with non-GPL modules."
#warning "This will break page tracking when the fglrx kernel module is used."
#undef CONFIG_MEM_MIRROR
@@ -86,7 +83,6 @@
#include <asm/unistd.h> /* for installing the patch wrapper */
#include <linux/module.h>
-#include <linux/config.h>
#include <linux/kernel.h>
#include <linux/fs.h>
#include <linux/proc_fs.h>

View File

@ -0,0 +1,73 @@
--- common/lib/modules/fglrx/build_mod/firegl_public.c 2006-12-18 10:58:15.000000000 -0500
+++ common/lib/modules/fglrx/build_mod/firegl_public.c 2006-12-18 11:14:04.000000000 -0500
@@ -181,6 +181,70 @@
int errno;
#endif // __ia64__
+#if defined(__i386__)
+#define __syscall_return(type, res) \
+do { \
+ if ((unsigned long)(res) >= (unsigned long)(-(128 + 1))) { \
+ errno = -(res); \
+ res = -1; \
+ } \
+ return (type) (res); \
+} while (0)
+#define _syscall2(type,name,type1,arg1,type2,arg2) \
+type name(type1 arg1,type2 arg2) \
+{ \
+long __res; \
+__asm__ volatile ("push %%ebx ; movl %2,%%ebx ; int $0x80 ; pop %%ebx" \
+ : "=a" (__res) \
+ : "0" (__NR_##name),"ri" ((long)(arg1)),"c" ((long)(arg2)) \
+ : "memory"); \
+__syscall_return(type,__res); \
+}
+
+#define _syscall3(type,name,type1,arg1,type2,arg2,type3,arg3) \
+type name(type1 arg1,type2 arg2,type3 arg3) \
+{ \
+long __res; \
+__asm__ volatile ("push %%ebx ; movl %2,%%ebx ; int $0x80 ; pop %%ebx" \
+ : "=a" (__res) \
+ : "0" (__NR_##name),"ri" ((long)(arg1)),"c" ((long)(arg2)), \
+ "d" ((long)(arg3)) : "memory"); \
+__syscall_return(type,__res); \
+}
+#elif defined(__x86_64__)
+#define __syscall_clobber "r11","rcx","memory"
+#define __syscall "syscall"
+
+#define __syscall_return(type, res) \
+do { \
+ if ((unsigned long)(res) >= (unsigned long)(-127)) { \
+ errno = -(res); \
+ res = -1; \
+ } \
+ return (type) (res); \
+} while (0)
+#define _syscall2(type,name,type1,arg1,type2,arg2) \
+type name(type1 arg1,type2 arg2) \
+{ \
+long __res; \
+__asm__ volatile (__syscall \
+ : "=a" (__res) \
+ : "0" (__NR_##name),"D" ((long)(arg1)),"S" ((long)(arg2)) : __syscall_clobber ); \
+__syscall_return(type,__res); \
+}
+
+#define _syscall3(type,name,type1,arg1,type2,arg2,type3,arg3) \
+type name(type1 arg1,type2 arg2,type3 arg3) \
+{ \
+long __res; \
+__asm__ volatile (__syscall \
+ : "=a" (__res) \
+ : "0" (__NR_##name),"D" ((long)(arg1)),"S" ((long)(arg2)), \
+ "d" ((long)(arg3)) : __syscall_clobber); \
+__syscall_return(type,__res); \
+}
+#endif
+
// int mlock(const void *addr, size_t len);
_syscall2(int, mlock, const void *, addr, size_t, len )
// int munlock(const void *addr, size_t len);

View File

@ -0,0 +1,33 @@
--- common/lib/modules/fglrx/build_mod/firegl_public.c 2007-03-29 23:48:46.000000000 +0200
+++ common/lib/modules/fglrx/build_mod/firegl_public.c 2007-03-30 00:15:21.000000000 +0200
@@ -5055,7 +5057,6 @@
*/
unsigned int ATI_API_CALL KAS_SlabCache_Destroy(void* hSlabCache)
{
- unsigned int ret = 0;
kasSlabCache_t* slabcache_obj = (kasSlabCache_t*)hSlabCache;
DBG_ENTER("0x%08X", hSlabCache);
@@ -5069,18 +5070,11 @@
DBG_TRACE("destroying slab object '%s'", slabcache_obj->name);
- if (kmem_cache_destroy(slabcache_obj->cache) == 0)
- {
- ret = 1;
- slabcache_obj->cache = NULL;
- }
- else
- {
- DBG_ERROR("destroying failed");
- }
+ kmem_cache_destroy(slabcache_obj->cache);
+ slabcache_obj->cache = NULL;
- DBG_LEAVE("%d", ret);
- return ret;
+ DBG_LEAVE("1");
+ return 1;
}
/** \brief Allocate an entry in a Slab Cache

View File

@ -0,0 +1,11 @@
--- common/lib/modules/fglrx/build_mod/firegl_public.c 2007-03-29 23:48:46.000000000 +0200
+++ common/lib/modules/fglrx/build_mod/firegl_public.c 2007-03-30 00:15:21.000000000 +0200
@@ -171,6 +171,8 @@
#endif
#endif
+#include <linux/freezer.h>
+
#include <linux/kmod.h>
// To enable DBG_* macros set this variable to nonzero

View File

@ -0,0 +1,22 @@
=== modified file 'common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh'
--- common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2007-02-09 12:25:40 +0000
+++ common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2007-02-09 12:28:54 +0000
@@ -46,7 +46,7 @@
getXuser;
if [ x"$XAUTHORITY" != x"" ]; then
export DISPLAY=":$displaynum"
- su $user -c "/usr/X11R6/bin/aticonfig --set-powerstate=1 --effective=now"
+ su $user -c "/opt/bin/aticonfig --set-powerstate=1 --effective=now"
fi
done
else
@@ -56,7 +56,7 @@
getXuser;
if [ x"$XAUTHORITY" != x"" ]; then
export DISPLAY=":$displaynum"
- su $user -c "/usr/X11R6/bin/aticonfig --set-powerstate=3 --effective=now"
+ su $user -c "/opt/bin/aticonfig --set-powerstate=3 --effective=now"
fi
done
fi

View File

@ -0,0 +1,32 @@
diff -ur common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh
--- common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-07-28 04:22:36.000000000 +0100
+++ common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-08-04 12:19:42.000000000 +0100
@@ -17,6 +17,10 @@
fi
}
+aticonfig='/opt/ati/bin/aticonfig'
+
+# default high power state
+default_state=`$aticonfig --lsp | grep 'default state' | cut -c 3`
grep -q closed /proc/acpi/button/lid/*/state
if [ $? = 0 ]; then
@@ -46,7 +50,7 @@
getXuser;
if [ x"$XAUTHORITY" != x"" ]; then
export DISPLAY=":$displaynum"
- su $user -c "/usr/X11R6/bin/aticonfig --set-powerstate=1 --effective=now"
+ su $user -c "$aticonfig --set-powerstate=1 --effective=now"
fi
done
else
@@ -56,7 +60,7 @@
getXuser;
if [ x"$XAUTHORITY" != x"" ]; then
export DISPLAY=":$displaynum"
- su $user -c "/usr/X11R6/bin/aticonfig --set-powerstate=3 --effective=now"
+ su $user -c "$aticonfig --set-powerstate=$default_state --effective=now"
fi
done
fi

View File

@ -0,0 +1,20 @@
#!/sbin/runscript
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/files/atieventsd.init,v 1.3 2007/05/18 23:58:01 marienz Exp $
depend() {
need acpid
}
start() {
ebegin "Starting ${SVCNAME}"
start-stop-daemon --start --exec /opt/sbin/atieventsd -- ${ATIEVENTSDOPTS}
eend $?
}
stop() {
ebegin "Stopping ${SVCNAME}"
start-stop-daemon --stop --quiet --exec /opt/sbin/atieventsd
eend $?
}

View File

@ -0,0 +1,22 @@
#!/sbin/runscript
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/files/atieventsd.rc6,v 1.2 2006/08/04 12:20:19 chrb Exp $
depend() {
need acpid
}
start() {
start-stop-daemon --start --pidfile /var/run/atieventsd.pid \
--exec /opt/ati/sbin/atieventsd -- ${ATIEVENTSDOPTS}
local pid=`pidof atieventsd`
echo $pid > /var/run/atieventsd.pid
eend $?
}
stop() {
start-stop-daemon --stop --quiet --pidfile /var/run/atieventsd.pid
eend $?
}

View File

@ -0,0 +1,32 @@
# libGL.la - a libtool library file
# Generated by ltmain.sh - GNU libtool 1.4 (1.920 2001/04/24 23:26:18)
#
# Please DO NOT delete this file!
# It is necessary for linking the library.
# The name that we can dlopen(3).
dlname='libGL.so.1'
# Names of this library.
library_names='libGL.so.${libmajor}.${libminor} libGL.so.${libmajor} libGL.so'
# The name of the static archive.
old_library=''
# Libraries that this one depends upon.
dependency_libs='-L/usr/${libdir} -lX11 -lXext -ldl'
# Version information for libGL.
current=1
age=0
revision=${revision}
# Is this an already installed library?
installed=yes
# Files to dlopen/dlpreopen
dlopen=''
dlpreopen=''
# Directory that this library needs to be installed in:
libdir='/usr/${libdir}'