Merge branch '10-add-ebuild-for-duplicati' into 'master'

10 add ebuild for duplicati

Closes #10

See merge request !67
This commit is contained in:
Manuel Friedli 2016-05-24 01:01:23 +02:00
commit 1e9cb04f7b
8 changed files with 213 additions and 2 deletions

View File

@ -0,0 +1,6 @@
AUX duplicati-1.3.4-filenames-casesensitive.patch 3852 SHA256 2b21530fad665c56377041b2cd4403303e552d3396c27c720eef730c2ccce35a SHA512 b8a5b0993c484d358bcd0bd5619bce4bf991afadc2b4c393a0272900fbb5bc9112bf1a12ea92385538558b587ec3369ef0fce168d1ed04183f14c00582e88523 WHIRLPOOL 74d18427ce64d608b31d172cfcd3c95538cb971635f98b6cc67cc4df282cb0856f9864e23a6d1c12ff8237627241fb1a1e413f329f20722e70e6b20835c00495
AUX duplicati-1.3.4-patch-Makefile.patch 2032 SHA256 29b6e0ca987c24622fb7562b791ee387e6b9e31f18d1e9733c89a5cf83d2db51 SHA512 b3a8dacb14a06a9b50747bc829b213a9d1f2af3b12583ca12ee51763ac73419cbb035860fd2ceef0cf41447c2e80c944b8655b5023fc7a87b2fe5364dd43062f WHIRLPOOL f21bd7262133fa25f77b2019092fa9560342f7a93ecf50d90086fd7744e4ef0176e433d77ae365ee888d63bde98b7233c3f7406d87cdd9e82ba6bb5457154e99
AUX duplicati-1.3.4-remove-unsigned-backends.patch 1899 SHA256 cc962d1b4243d7f8a6f18f541eb9d6a503add0d95b67e384f1a611b875a7e973 SHA512 960e45e8f8bd0a59bbd1b9adb9f60758957916158b7e6609e5c3a7fdae4b120842ee14a8ae3152ca00999798c9c1e3bb953fcff4dc4e8d748d8942cb669c1090 WHIRLPOOL 9bb46c12dd8bf4298a59cba25616a05624f6eab2027ddbc43be1bf9cd617795d7fdcc2303e3e18f114d6daa2698560856dd3a00c4b11d243d8fd2a8cf7078cf5
DIST duplicati-1.3.4.tar.gz 11840281 SHA256 abae8876b536d4f1e63b07297ea0b26ad9a2026e46593be661d45f95d2348581 SHA512 e92c178715df0d6d5794720988ccb4342aaf9d6e92813316b7c9214364d7735eaeb178d2dc413a91acc3e7e7a1a4ba1821e8ef7989897a55add66f63adcbc7a5 WHIRLPOOL 3d1d70e44f662adb7e24324bc82bbfd1c9b8e6596136ffd69dec78cd60ecee908b604110e52ddc79104e071db97efc27bb30d45f78464043d11d1259b3672b6b
EBUILD duplicati-1.3.4.ebuild 842 SHA256 0cbfd36674993d05c9b77009b4dc8d0ce70bc0e11ee822d41f303c18c6a5b839 SHA512 324bb5ee20ba2bee9708073945866fd411c1ee19299cb51b2bcbc27c3039aa2fe503a146a9708dc9d950cb7475d0858e3cd5084c08589663e1f4c6bdfa9678ca WHIRLPOOL 3e267834472843371a15004b19033e81639e68ee986a86aaaeb8dbf3eb92b622ceb6413dd8074097a4c154786eda97e626709c3a66ac39e67616e14323199fda
MISC metadata.xml 248 SHA256 7b43be15755627edf5c12cf1b50c607d781558640bf8375d685d51d7ade99a32 SHA512 29f9b96b0a77546cce6a8bffd82fae2fd0939d32a7a05ffd0d91f9250a019a3ddaa599b93988c82daabb9c4c4b284dd947e2c47f6ca7727b8539cffa91bcb8c2 WHIRLPOOL 993013c9878ead35469db13d3072f694a341ee654182e0c31d0678f5dd6de4bdc8d59a0b7bb6d685dc41ea6b55dac518cd8034131baea8002170c680e50304d1

View File

@ -0,0 +1,43 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
inherit eutils mono-env
DESCRIPTION="A backup client that securely stores encrypted, incremental, compressed backups."
HOMEPAGE="http://www.duplicati.com/"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64"
CDEPEND=""
DEPEND=">=dev-lang/mono-4.4.0.40"
RDEPEND=""
PATCHES=(
"${FILESDIR}/${P}-filenames-casesensitive.patch"
"${FILESDIR}/${P}-remove-unsigned-backends.patch"
"${FILESDIR}/${P}-patch-Makefile.patch"
)
MY_MAKE_DIR="${S}/Installer/Makefile"
src_prepare() {
for p in "${PATCHES[@]}" ; do
epatch "${p}"
done
}
src_compile() {
cd "${MY_MAKE_DIR}"
emake translations
}
src_install() {
cd "${MY_MAKE_DIR}"
emake package
}

View File

@ -0,0 +1,78 @@
diff --git a/Duplicati/Library/Backend/FTP/Duplicati.Library.Backend.FTP.csproj b/Duplicati/Library/Backend/FTP/Duplicati.Library.Backend.FTP.csproj
index 2b4c161..10902eb 100644
--- a/Duplicati/Library/Backend/FTP/Duplicati.Library.Backend.FTP.csproj
+++ b/Duplicati/Library/Backend/FTP/Duplicati.Library.Backend.FTP.csproj
@@ -64,7 +64,7 @@
<Compile Include="FTPUI.cs">
<SubType>UserControl</SubType>
</Compile>
- <Compile Include="FTPUI.designer.cs">
+ <Compile Include="FTPUI.Designer.cs">
<DependentUpon>FTPUI.cs</DependentUpon>
</Compile>
<Compile Include="Properties\AssemblyInfo.cs" />
diff --git a/Duplicati/Library/Backend/File/Duplicati.Library.Backend.File.csproj b/Duplicati/Library/Backend/File/Duplicati.Library.Backend.File.csproj
index 0b03e11..5e5ce7f 100644
--- a/Duplicati/Library/Backend/File/Duplicati.Library.Backend.File.csproj
+++ b/Duplicati/Library/Backend/File/Duplicati.Library.Backend.File.csproj
@@ -64,7 +64,7 @@
<Compile Include="FileUI.cs">
<SubType>UserControl</SubType>
</Compile>
- <Compile Include="FileUI.designer.cs">
+ <Compile Include="FileUI.Designer.cs">
<DependentUpon>FileUI.cs</DependentUpon>
</Compile>
<Compile Include="Properties\AssemblyInfo.cs" />
diff --git a/Duplicati/Library/Backend/S3/Duplicati.Library.Backend.S3.csproj b/Duplicati/Library/Backend/S3/Duplicati.Library.Backend.S3.csproj
index ddc0f47..4dfadfc 100644
--- a/Duplicati/Library/Backend/S3/Duplicati.Library.Backend.S3.csproj
+++ b/Duplicati/Library/Backend/S3/Duplicati.Library.Backend.S3.csproj
@@ -77,7 +77,7 @@
<Compile Include="S3UI.cs">
<SubType>UserControl</SubType>
</Compile>
- <Compile Include="S3UI.designer.cs">
+ <Compile Include="S3UI.Designer.cs">
<DependentUpon>S3UI.cs</DependentUpon>
</Compile>
<Compile Include="S3Wrapper.cs" />
diff --git a/Duplicati/Library/Backend/SSH/Duplicati.Library.Backend.SSH.csproj b/Duplicati/Library/Backend/SSH/Duplicati.Library.Backend.SSH.csproj
index 4c3fae1..111ece8 100644
--- a/Duplicati/Library/Backend/SSH/Duplicati.Library.Backend.SSH.csproj
+++ b/Duplicati/Library/Backend/SSH/Duplicati.Library.Backend.SSH.csproj
@@ -78,7 +78,7 @@
<Compile Include="SSHUI.cs">
<SubType>UserControl</SubType>
</Compile>
- <Compile Include="SSHUI.designer.cs">
+ <Compile Include="SSHUI.Designer.cs">
<DependentUpon>SSHUI.cs</DependentUpon>
</Compile>
<Compile Include="OutputStreamWrapper.cs" />
diff --git a/Duplicati/Library/Backend/TahoeLAFS/Duplicati.Library.Backend.TahoeLAFS.csproj b/Duplicati/Library/Backend/TahoeLAFS/Duplicati.Library.Backend.TahoeLAFS.csproj
index 1e13958..37d51dc 100644
--- a/Duplicati/Library/Backend/TahoeLAFS/Duplicati.Library.Backend.TahoeLAFS.csproj
+++ b/Duplicati/Library/Backend/TahoeLAFS/Duplicati.Library.Backend.TahoeLAFS.csproj
@@ -113,7 +113,7 @@
<Compile Include="TahoeUI.cs">
<SubType>UserControl</SubType>
</Compile>
- <Compile Include="TahoeUI.designer.cs">
+ <Compile Include="TahoeUI.Designer.cs">
<DependentUpon>TahoeUI.cs</DependentUpon>
</Compile>
</ItemGroup>
diff --git a/Duplicati/Library/Backend/WEBDAV/Duplicati.Library.Backend.WEBDAV.csproj b/Duplicati/Library/Backend/WEBDAV/Duplicati.Library.Backend.WEBDAV.csproj
index 6ac8c03..9b945e6 100644
--- a/Duplicati/Library/Backend/WEBDAV/Duplicati.Library.Backend.WEBDAV.csproj
+++ b/Duplicati/Library/Backend/WEBDAV/Duplicati.Library.Backend.WEBDAV.csproj
@@ -76,7 +76,7 @@
<Compile Include="WebDAVUI.cs">
<SubType>UserControl</SubType>
</Compile>
- <Compile Include="WebDAVUI.designer.cs">
+ <Compile Include="WebDAVUI.Designer.cs">
<DependentUpon>WebDAVUI.cs</DependentUpon>
</Compile>
</ItemGroup>

View File

@ -0,0 +1,56 @@
diff --git a/Installer/Makefile/Makefile b/Installer/Makefile/Makefile
index 5528c7e..ba8e11f 100644
--- a/Installer/Makefile/Makefile
+++ b/Installer/Makefile/Makefile
@@ -2,20 +2,14 @@ BUILD_TOOL=xbuild
BUILD_ARGS=/property:Platform=Any\ CPU /property:Configuration=Release
OUTPUT_ARGS=/property:OutputPath=bin/Release
SOURCE_DIR=../../.
-PACKAGE_DIR=./pkg
+PACKAGE_DIR=${D}/.
PKG_TARGET=$(PACKAGE_DIR)/usr/lib/duplicati
LOCALIZATION_TOOL=mono $(SOURCE_DIR)/Duplicati/Localization/LocalizationTool.exe
all: package
-Duplicati-v1.sln:
- patch -d "$(SOURCE_DIR)" -i patch-1-remove-scheduler -o Duplicati-v1.sln Duplicati.sln
-
-Duplicati-v2.sln: Duplicati-v1.sln
- patch -d "$(SOURCE_DIR)" -i patch-2-remove-unsigned-backends -o Duplicati-v2.sln Duplicati-v1.sln
-
-build: Duplicati-v2.sln
- $(BUILD_TOOL) $(BUILD_ARGS) "$(SOURCE_DIR)/Duplicati-v2.sln"
+build:
+ $(BUILD_TOOL) $(BUILD_ARGS) "$(SOURCE_DIR)/Duplicati.sln"
$(BUILD_TOOL) $(BUILD_ARGS) $(OUTPUT_ARGS) "$(SOURCE_DIR)/Duplicati/Library/Backend/SSH/Duplicati.Library.Backend.SSH.csproj"
$(BUILD_TOOL) $(BUILD_ARGS) $(OUTPUT_ARGS) "$(SOURCE_DIR)/Duplicati/Library/Backend/TahoeLAFS/Duplicati.Library.Backend.TahoeLAFS.csproj"
$(BUILD_TOOL) $(BUILD_ARGS) "$(SOURCE_DIR)/BuildTools/LocalizationTool/LocalizationTool.sln"
@@ -31,10 +25,6 @@ translations: build
$(LOCALIZATION_TOOL) build
package:
- if [ -e "$(PACKAGE_DIR)" ]; then \
- rm -rf "$(PACKAGE_DIR)"; \
- fi
- mkdir "$(PACKAGE_DIR)"
mkdir "$(PACKAGE_DIR)/usr"
mkdir "$(PACKAGE_DIR)/usr/lib"
mkdir "$(PACKAGE_DIR)/usr/bin"
@@ -79,16 +69,6 @@ package:
chmod +x "$(PACKAGE_DIR)/usr/bin/duplicati"
chmod +x "$(PACKAGE_DIR)/usr/bin/duplicati-commandline"
-
- if [ -e "duplicati.tar" ]; then \
- rm -rf "duplicati.tar"; \
- fi
- if [ -e "duplicati.tar.gz" ]; then \
- rm -rf "duplicati.tar.gz"; \
- fi
-
- tar -C "$(PACKAGE_DIR)" -cf "duplicati.tar" .
- gzip --best "duplicati.tar"
clean:
rm -rf "$(SOURCE_DIR)/Duplicati-v1.sln"

View File

@ -0,0 +1,20 @@
--- Duplicati.sln.old 2011-12-06 18:21:00.000000000 +0100
+++ Duplicati.sln 2011-12-06 20:15:33.000000000 +0100
@@ -11,8 +11,6 @@
EndProject
Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "Duplicati.Library.Backend.FTP", "Duplicati\Library\Backend\FTP\Duplicati.Library.Backend.FTP.csproj", "{F61679A9-E5DE-468A-B5A4-05F92D0143D2}"
EndProject
-Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "Duplicati.Library.Backend.SSH", "Duplicati\Library\Backend\SSH\Duplicati.Library.Backend.SSH.csproj", "{6BA21DCB-1701-4936-B177-3B6D4DE3474E}"
-EndProject
Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "Duplicati.Library.Compression", "Duplicati\Library\Compression\Duplicati.Library.Compression.csproj", "{19ECCE09-B5EB-406C-8C57-BAC66997D469}"
EndProject
Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "Duplicati.Library.Encryption", "Duplicati\Library\Encryption\Duplicati.Library.Encryption.csproj", "{94484FDB-2EFA-4CF0-9BE6-A561157B4F87}"
@@ -49,8 +47,6 @@
EndProject
Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "Duplicati.Library.Modules.Builtin", "Duplicati\Library\Modules\Builtin\Duplicati.Library.Modules.Builtin.csproj", "{52826615-7964-47FE-B4B3-1B2DBDF605B9}"
EndProject
-Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "Duplicati.Library.Backend.TahoeLAFS", "Duplicati\Library\Backend\TahoeLAFS\Duplicati.Library.Backend.TahoeLAFS.csproj", "{C0270709-2A40-43B5-8CF1-69581B9FA2A1}"
-EndProject
Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "Duplicati.Library.Backend.SkyDrive", "Duplicati\Library\Backend\SkyDrive\Duplicati.Library.Backend.SkyDrive.csproj", "{CCD76347-7DC7-4B42-B7E1-E500E624CAC3}"
EndProject
Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "Duplicati.Library.Backend.GoogleDocs", "Duplicati\Library\Backend\GoogleDocs\Duplicati.Library.Backend.GoogleDocs.csproj", "{42C91180-11EB-4590-82EA-80FE9D4DEBEC}"

View File

@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>manuel@fritteli.ch</email>
<name>Manuel Friedli</name>
</maintainer>
</pkgmetadata>

View File

@ -1,3 +1,3 @@
DIST certbot-apache-0.6.0.tar.gz 686826 SHA256 58eaa6be4ae90af07d682296e42dbac924b5602c51002445059596313e182a09 SHA512 966fdbff13ac9651ebb5fafae86a58a45538d57a43eb6d157358bbecef4286634bb61dd13b94e0ca5b006980a35cc5fe55b4a12efdeadc2530653d844516c926 WHIRLPOOL 0bd424395b9002a04f6c900b208aea758f74e9864d75f6aa87fc30573f046c63f9791aa8bcce0a5452831192d1579e9b52fda5ed77befd6e4f361dab976d6369
EBUILD certbot-apache-0.6.0.ebuild 1051 SHA256 ead789957c63cb1d0951bca583256109f5deb55c52b58a9b3772afceb5a0f64b SHA512 ca49a904ed44ec950bea4c3864cb7f8e8c61d5a3d74111fe5be5a3f478a5a9a4c4f9d2beb7d216dfb86dfd05020236bce7c4e0c9f81c52a68316b88e152b8bbf WHIRLPOOL 5f21a34c264de958564ee199a6b819211339a0280b22b1447005d72b5a8f1f538af729180b20dadf6c49ffa98e841e0b568f3cd85e26da66d5a7f4c27de98134
MISC metadata.xml 249 SHA256 115c610dd9584e34b88bae272abb3bc8d0088f9980406491ecb01d2ad470647e SHA512 17fba255d5a76a284ce046103fcc05c4c8a217d5fe3c2f2c0cf78fb2271c641256b2e1fb5d3dc6c09d5522a16e0759ac3d15d70e4e55b27b4f317247f39480ba WHIRLPOOL 6c83046dea413ce20248f3d8ba57174559154dec2901fff530051eddeeb970280b87e8ee0052312fce6f430139881392574e3f64b6b954135bb630ed8df1cc70
MISC metadata.xml 248 SHA256 7b43be15755627edf5c12cf1b50c607d781558640bf8375d685d51d7ade99a32 SHA512 29f9b96b0a77546cce6a8bffd82fae2fd0939d32a7a05ffd0d91f9250a019a3ddaa599b93988c82daabb9c4c4b284dd947e2c47f6ca7727b8539cffa91bcb8c2 WHIRLPOOL 993013c9878ead35469db13d3072f694a341ee654182e0c31d0678f5dd6de4bdc8d59a0b7bb6d685dc41ea6b55dac518cd8034131baea8002170c680e50304d1

View File

@ -3,6 +3,6 @@
<pkgmetadata>
<maintainer type="person">
<email>manuel@fritteli.ch</email>
<name>Manuel Friedlir</name>
<name>Manuel Friedli</name>
</maintainer>
</pkgmetadata>