ha! he.net uses dyndns2 protocol, so no patching for noip is needed! thus i threw away my custom ebuild for 3.8.0

This commit is contained in:
Manuel Friedli 2011-05-15 09:45:39 +00:00
parent 00310d0bba
commit 2e19a1a20e
4 changed files with 0 additions and 191 deletions

View file

@ -1,12 +1,8 @@
AUX ddclient-3.8.0-everydns.patch 3455 RMD160 cfd93bd916a6165eaac75129881b7499b6268b96 SHA1 021feb6724d895207d50eeaf063b8560fb7d95cf SHA256 fb8d3703ea465818970efd9ebae6acff7de0177db060d7b1ba43016764ba994d
AUX ddclient-everydns.patch 3454 RMD160 e9ea63e8a055e7c6070c3b0b0b4dbc8627a162fd SHA1 b9ca9ba95f2412e81c8c24b0105278750dbb46b2 SHA256 72efe00568fe3691824e0335509a9302e739558c1955bcca1c1b9e6296b824e9
AUX ddclient-noip-he-dot-net.patch 500 RMD160 2b993a9265e610150f7d947ccc1356295f5e3120 SHA1 097b43fe3df4f8f5665808572304699cd835761c SHA256 e38de51feec2ad49276be98c260db9fe0b78d18f93bccc84de40623d70464a05
AUX ddclient-reasonable-security.patch 858 RMD160 0be9d1a9412225361f6352322ee5af6279730393 SHA1 171f220000c5ada3208f9f5765ef3347c7cbde7d SHA256 4ae67c01b41e0ae2f52b60e43072a872373201cc81f92108cd674b89eabda044
AUX ddclient.confd 97 RMD160 dab278d7ed0ab8fe9f01c072be549d532f20b5d4 SHA1 90ede573df78aa242b9fec7f6d9f05f0c937fb2b SHA256 7a05a1c016dcffa2033da00e8a58072d0df33c31bc8b96170929032567cb44ab
AUX ddclient.init 732 RMD160 53c6674ff80bf0d222178bde2a2d28a3cd9ee635 SHA1 3b65b01e7a7e1d85843f75c701fbb43d5d124ccd SHA256 2e7aecd2ffe978006632d78bb3a7c5eede2490f6af769399c2bb35c531e11146
AUX ddclient.initd 1227 RMD160 033f85c34d5126ce259687c565e16e78f01c4a6e SHA1 cc5e7fff44cba718090178db4cea756727007796 SHA256 9b2767317351437dcf71c59ef4ab15af0e4953465b17774980449885059aa925
AUX ddclient.rc6 718 RMD160 8faeb700539275e8ede58c857981b858e36c32fe SHA1 514ff1f62675f75203751770d808750a645c2df4 SHA256 8e94f53e278146665cf4f24427c84799767affef3742540a943b7379678171ad
DIST ddclient-3.7.3.tar.gz 42034 RMD160 df40a809132102b9326fa7e9d735723e1de8ed37 SHA1 aa4368a58e5b344bffd6561fc7fed304c007fe84 SHA256 f1f57fdca170d9349cb99a3b8b33672d983e0e41c43c2bbb940927380ee12962
DIST ddclient-3.8.0.tar.gz 45893 RMD160 771ed13aa248c13af11e0466888513418bae98fb SHA1 ff889adacf916bebb25522d9cc1eda0e9593a7f4 SHA256 88f0f1cfafd2d7a813e72c3a3f1f2a08e9bf06ccd1d49ddb3f942dd4b9331fb3
EBUILD ddclient-3.7.3-r1.ebuild 2410 RMD160 fb93c0d02b31024477a92bde52446237d580feda SHA1 434a77b141cd950cddf35b013e6fa79f574b1eba SHA256 843ddef8a25b1259e65818df166e86d58a9f984cbb4408872d158f77dce2bbf1
EBUILD ddclient-3.8.0.ebuild 2460 RMD160 3715881f5b54a66ef018492d89f0d9e9da284cfa SHA1 50a5d820c8b6f0dc8c215aacdb35e11c8d0ad179 SHA256 7c1d213835895ad2056fc7a73d4c45aaca01d5a7f17a61e9e281c3ebbee88a08

View file

@ -1,79 +0,0 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ddclient-3.8.0.ebuild,v 1.2 2009/02/25 13:43:06 gentoofan23 Exp $
inherit eutils
DESCRIPTION="Perl updater client for dynamic DNS services"
HOMEPAGE="http://ddclient.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="ssl"
RDEPEND=">=dev-lang/perl-5.1
ssl? ( dev-perl/IO-Socket-SSL )"
pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 -1 ${PN}
}
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${PN}-reasonable-security.patch"
epatch "${FILESDIR}/${PN}-noip-he-dot-net.patch"
epatch "${FILESDIR}/${P}-everydns.patch"
einfo "Applying version string fix"
if ! sed -i "s/3\.7\.1/$PV/" "$PN"; then
eerror "Failed to update ddclient's internal version string"
eerror 'ddclient 3.7.2 will erroneously report a version of 3.7.1'
fi
# Remove pid line, because it is specified in /etc/conf.d/ddclient
einfo "Applying PID setup"
if ! sed -i "/^pid=*/d" "sample-etc_${PN}.conf"; then
eerror "Failed to remove pid from /etc/$PN/$PN.conf"
eerror "Please set the PID in /etc/conf.d/$PN, not /etc/$PN/$PN.conf"
fi
if ! use ssl; then
einfo "Disabling ssl per your useflags"
sed -i "/^ssl=*/d" "sample-etc_${PN}.conf" ||
eerror "Failed to remove ssl from /etc/$PN/$PN.conf"
fi
}
src_install() {
dosbin ${PN} || die "dosbin failed"
dodoc README* Change* COPYRIGHT sample*
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
keepdir /var/{cache,run}/${PN}
# Filename of sample conf - use live filename if available
local sample=${PN}.conf
[[ -e "/etc/${PN}/${sample}" ]] && sample="${sample}.sample"
insinto /etc/${PN}
insopts -m 0640 -o root -g ${PN}
newins sample-etc_${PN}.conf "${sample}" || die "newins conf failed"
}
pkg_postinst() {
# ensure the directories are owned by the user:group for this pkg
chown ${PN}:${PN} /var/{cache,run}/${PN}
use ssl && return
ewarn
ewarn "$PN will not have support for ssl, which means your dynamic DNS account"
ewarn "information -- including your password -- will be sent over the Internet in the"
ewarn "clear. To secure your information, add 'ssl' to your USEflags,"
ewarn "emerge -N ddclient, and add 'ssl=yes' to /etc/$PN/$PN.conf"
ewarn
}

View file

@ -1,93 +0,0 @@
--- ddclient.orig 2011-05-12 09:48:40.000000000 +0000
+++ ddclient 2011-05-12 09:54:27.000000000 +0000
@@ -524,6 +524,16 @@
$variables{'service-common-defaults'},
),
},
+ 'everydns' => {
+ 'updateable' => undef,
+ 'update' => \&nic_everydns_update,
+ 'examples' => \&nic_everydns_examples,
+ 'variables' => merge(
+ { 'server' => setv(T_FQDNP, 1, 0, 1, 'dyn.everydns.net', undef) },
+ { 'min-interval' => setv(T_DELAY, 0, 0, 1, 0, interval('15m')) },
+ $variables{'service-common-defaults'},
+ ),
+ },
);
$variables{'merged'} = merge($variables{'global-defaults'},
$variables{'service-common-defaults'},
@@ -3377,6 +3387,73 @@
}
}
}
+######################################################################
+## nic_everydns_examples
+######################################################################
+sub nic_everydns_examples {
+ return <<EoEXAMPLE;
+o 'everydns'
+
+The 'everydns' protocol is the protocol used by the free dynamic
+DNS service offered by EveryDNS at www.everydns.net. So far it actually ignores the
+value of the domain, it just updates all domains associated with the account
+that belongs to the given credentials
+
+Configuration variables applicable to the 'everydns' protocol are:
+ protocol=everydns ##
+ server=dyn.everydns.net ## defaults to members.dyndns.org
+ login=service-login ## login name and password registered with the service
+ password=service-password ##
+ domain.name ## the domain registered with the service.
+
+Example ${program}.conf file entries:
+ ## single host update
+ protocol=everydns, \\
+ login=my-everydns.net-login, \\
+ password=my-everydns.net-password \\
+ my-example-domain.com
+
+EoEXAMPLE
+}
+######################################################################
+## nic_everydns_update
+######################################################################
+sub nic_everydns_update {
+ debug("\nnic_everydns_update -------------------");
+
+ ## update each configured domain
+ foreach my $h (@_) {
+ my $ip = delete $config{$h}{'wantip'};
+ info("setting IP address to %s for %s", $ip, $h);
+ verbose("UPDATE:","updating %s", $h);
+
+ my $url;
+ $url = "http://$config{$h}{'server'}/index.php";
+ $url .= "?ver=0.1";
+ $url .= "&ip=$ip" if $ip;
+ # $url .= "&domain=$d" if $d;
+
+ my $reply = geturl(opt('proxy'), $url, $config{$h}{'login'}, $config{$h}{'password'});
+ if (!defined($reply) || !$reply) {
+ failed("updating %s: Could not connect to %s.", $h, $config{$h}{'server'});
+ last;
+ }
+ last if !header_ok($h, $reply);
+
+ my @reply = split /\n/, $reply;
+ if (grep /^Exit Code: 0$/i, @reply) {
+ $config{$h}{'ip'} = $ip;
+ $config{$h}{'mtime'} = $now;
+ $config{$h}{'status'} = 'good';
+ success("updating %s: good: IP address set to %s", $h, $ip);
+ } else {
+ $config{$h}{'status'} = 'failed';
+ warning("SENT: %s", $url) unless opt('verbose');
+ warning("REPLIED: %s", $reply);
+ failed("updating %s: Invalid reply.", $h);
+ }
+ }
+}
######################################################################
# vim: ai ts=4 sw=4 tw=78 :

View file

@ -1,15 +0,0 @@
--- ddclient.orig 2009-01-27 19:14:02.000000000 +0000
+++ ddclient 2011-05-12 09:48:01.000000000 +0000
@@ -2460,9 +2460,9 @@
info("setting IP address to %s for %s", $ip, $hosts);
verbose("UPDATE:","updating %s", $hosts);
- my $url = "http://$config{$h}{'server'}/nic/update?system=";
- $url .= 'noip';
- $url .= "&hostname=$hosts";
+ my $url = "http://$config{$h}{'server'}/nic/update?";
+ $url .= "hostname=";
+ $url .= "$hosts";
$url .= "&myip=";
$url .= $ip if $ip;