intermediate ebuild for app-backup/duplicati-1.3.4

This commit is contained in:
Manuel Friedli 2016-05-17 23:47:12 +02:00
parent 42f06e95bc
commit 3560f66637
3 changed files with 104 additions and 0 deletions

View File

@ -0,0 +1,3 @@
AUX duplicati-1.3.4-filenames-casesensitive.patch 3852 SHA256 2b21530fad665c56377041b2cd4403303e552d3396c27c720eef730c2ccce35a SHA512 b8a5b0993c484d358bcd0bd5619bce4bf991afadc2b4c393a0272900fbb5bc9112bf1a12ea92385538558b587ec3369ef0fce168d1ed04183f14c00582e88523 WHIRLPOOL 74d18427ce64d608b31d172cfcd3c95538cb971635f98b6cc67cc4df282cb0856f9864e23a6d1c12ff8237627241fb1a1e413f329f20722e70e6b20835c00495
DIST duplicati-1.3.4.tar.gz 11840281 SHA256 abae8876b536d4f1e63b07297ea0b26ad9a2026e46593be661d45f95d2348581 SHA512 e92c178715df0d6d5794720988ccb4342aaf9d6e92813316b7c9214364d7735eaeb178d2dc413a91acc3e7e7a1a4ba1821e8ef7989897a55add66f63adcbc7a5 WHIRLPOOL 3d1d70e44f662adb7e24324bc82bbfd1c9b8e6596136ffd69dec78cd60ecee908b604110e52ddc79104e071db97efc27bb30d45f78464043d11d1259b3672b6b
EBUILD duplicati-1.3.4.ebuild 593 SHA256 c1959304434bcb07134642e7d27d9f0814b45128b22ccf9c51e843c010832d2f SHA512 c976d065eb9a1a0e6461991b6a7aed2964e5d28ff0cbfdadcad7262dd313b82991c9e0ec29e218cbdb4ce1f9456976dd6e5008606868a3a85d73d47877ef4b1b WHIRLPOOL c7217311d4ada1adeee4087f2cd673505b1db45e7be20105937f8c75c49f56d490e2d1b8b0979e016bd9d9211c05755d58194d26ec106bec19340d3ab0dd92d3

View File

@ -0,0 +1,23 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
inherit eutils mono
DESCRIPTION="Duplicati is a backup client that securely stores encrypted, incremental, compressed backups on cloud storage services and remote file servers."
HOMEPAGE="http://www.duplicati.com/"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL"
SLOT="0"
KEYWORDS="~amd64"
CDEPEND=""
DEPEND=">=dev-lang/mono-4.0.5.1"
RDEPEND=""
src_prepare() {
epatch "${FILESDIR}/${P}-filenames-casesensitive.patch"
}

View File

@ -0,0 +1,78 @@
diff --git a/Duplicati/Library/Backend/FTP/Duplicati.Library.Backend.FTP.csproj b/Duplicati/Library/Backend/FTP/Duplicati.Library.Backend.FTP.csproj
index 2b4c161..10902eb 100644
--- a/Duplicati/Library/Backend/FTP/Duplicati.Library.Backend.FTP.csproj
+++ b/Duplicati/Library/Backend/FTP/Duplicati.Library.Backend.FTP.csproj
@@ -64,7 +64,7 @@
<Compile Include="FTPUI.cs">
<SubType>UserControl</SubType>
</Compile>
- <Compile Include="FTPUI.designer.cs">
+ <Compile Include="FTPUI.Designer.cs">
<DependentUpon>FTPUI.cs</DependentUpon>
</Compile>
<Compile Include="Properties\AssemblyInfo.cs" />
diff --git a/Duplicati/Library/Backend/File/Duplicati.Library.Backend.File.csproj b/Duplicati/Library/Backend/File/Duplicati.Library.Backend.File.csproj
index 0b03e11..5e5ce7f 100644
--- a/Duplicati/Library/Backend/File/Duplicati.Library.Backend.File.csproj
+++ b/Duplicati/Library/Backend/File/Duplicati.Library.Backend.File.csproj
@@ -64,7 +64,7 @@
<Compile Include="FileUI.cs">
<SubType>UserControl</SubType>
</Compile>
- <Compile Include="FileUI.designer.cs">
+ <Compile Include="FileUI.Designer.cs">
<DependentUpon>FileUI.cs</DependentUpon>
</Compile>
<Compile Include="Properties\AssemblyInfo.cs" />
diff --git a/Duplicati/Library/Backend/S3/Duplicati.Library.Backend.S3.csproj b/Duplicati/Library/Backend/S3/Duplicati.Library.Backend.S3.csproj
index ddc0f47..4dfadfc 100644
--- a/Duplicati/Library/Backend/S3/Duplicati.Library.Backend.S3.csproj
+++ b/Duplicati/Library/Backend/S3/Duplicati.Library.Backend.S3.csproj
@@ -77,7 +77,7 @@
<Compile Include="S3UI.cs">
<SubType>UserControl</SubType>
</Compile>
- <Compile Include="S3UI.designer.cs">
+ <Compile Include="S3UI.Designer.cs">
<DependentUpon>S3UI.cs</DependentUpon>
</Compile>
<Compile Include="S3Wrapper.cs" />
diff --git a/Duplicati/Library/Backend/SSH/Duplicati.Library.Backend.SSH.csproj b/Duplicati/Library/Backend/SSH/Duplicati.Library.Backend.SSH.csproj
index 4c3fae1..111ece8 100644
--- a/Duplicati/Library/Backend/SSH/Duplicati.Library.Backend.SSH.csproj
+++ b/Duplicati/Library/Backend/SSH/Duplicati.Library.Backend.SSH.csproj
@@ -78,7 +78,7 @@
<Compile Include="SSHUI.cs">
<SubType>UserControl</SubType>
</Compile>
- <Compile Include="SSHUI.designer.cs">
+ <Compile Include="SSHUI.Designer.cs">
<DependentUpon>SSHUI.cs</DependentUpon>
</Compile>
<Compile Include="OutputStreamWrapper.cs" />
diff --git a/Duplicati/Library/Backend/TahoeLAFS/Duplicati.Library.Backend.TahoeLAFS.csproj b/Duplicati/Library/Backend/TahoeLAFS/Duplicati.Library.Backend.TahoeLAFS.csproj
index 1e13958..37d51dc 100644
--- a/Duplicati/Library/Backend/TahoeLAFS/Duplicati.Library.Backend.TahoeLAFS.csproj
+++ b/Duplicati/Library/Backend/TahoeLAFS/Duplicati.Library.Backend.TahoeLAFS.csproj
@@ -113,7 +113,7 @@
<Compile Include="TahoeUI.cs">
<SubType>UserControl</SubType>
</Compile>
- <Compile Include="TahoeUI.designer.cs">
+ <Compile Include="TahoeUI.Designer.cs">
<DependentUpon>TahoeUI.cs</DependentUpon>
</Compile>
</ItemGroup>
diff --git a/Duplicati/Library/Backend/WEBDAV/Duplicati.Library.Backend.WEBDAV.csproj b/Duplicati/Library/Backend/WEBDAV/Duplicati.Library.Backend.WEBDAV.csproj
index 6ac8c03..9b945e6 100644
--- a/Duplicati/Library/Backend/WEBDAV/Duplicati.Library.Backend.WEBDAV.csproj
+++ b/Duplicati/Library/Backend/WEBDAV/Duplicati.Library.Backend.WEBDAV.csproj
@@ -76,7 +76,7 @@
<Compile Include="WebDAVUI.cs">
<SubType>UserControl</SubType>
</Compile>
- <Compile Include="WebDAVUI.designer.cs">
+ <Compile Include="WebDAVUI.Designer.cs">
<DependentUpon>WebDAVUI.cs</DependentUpon>
</Compile>
</ItemGroup>