added draft ebuild for www-apps/gitlab-git-http-server-0.2.9

This commit is contained in:
Manuel Friedli 2015-09-14 20:43:42 +02:00
parent db6817cdb3
commit 3eea63bf44
5 changed files with 96 additions and 0 deletions

View File

@ -0,0 +1,5 @@
AUX fix-Makefile-0.2.9.patch 385 SHA256 879ab15c1770414da4a3001664fd30a11a9e95436dc0539330a66c85659b6c8d SHA512 6332a20689061f5e1c712113788fed843409b466dec5f1e5eee98ccf37316a065294e9321f3c2d1aed5a164788d5c6b1724a67949cfe2917b8c2b6374fb8a0ef WHIRLPOOL 250eef6fa2526c4e25237c8ba7fafa8acf72cf5b1c549c1e45f60a1a21237e6865fcb0523ed60be0f1d206b27dfb876201ad8042077097d4ed37b0e154df7241
AUX gitlab-git-http-server.conf 222 SHA256 363b39f109219d478d3060b300115eddffd17988569ad485bfab0f4ad5cb5374 SHA512 f246cafbd4d7e7b7c30c24396751ff0d6f549934e87aad10e668b1bfe37de0bd319827dee2392919455ffd05977aa5a198a25d6664dda1d4100b42c303f20f1f WHIRLPOOL 901bc146461d532b1b9cedc506f9baf99a9064dd4e88adbdbd2761abf57814de5aca6fda990143618575a5a4865dd2b8789ed9ec3a6195f14a077eb12bc2c660
AUX gitlab-git-http-server.init 417 SHA256 0aefe5e8c85a98bb177ebd20e952051717381fe147a70488523d97e335d43f50 SHA512 70afebf1b382f2b1cc5cdf6bb6d22393161938a241aabadc4332296f430a4f73a38ba257ac0363f43f9a6329a1c04428060f64bc8f506c9bedf578333a3ae790 WHIRLPOOL 222eb1636a3c9fa3320e53bc9facb096cad4555a451b6ce504845798c1bd6518af0b1d839149373602dd2279007364c893d818d7ec7205c01132e7942b47c83c
DIST gitlab-git-http-server-0.2.9.tar.bz2 6801 SHA256 36032815fa262f939f77676f74f7b96977e87ba5fad953a37b71568766674a25 SHA512 e4a6f6dcd15bf32688e0580d25a28de82f6e37108615e63b3317ac53402e1c4baf46d5b9351687de2755546f2fcedea802a88d68374f8a98aea47a2edd9e3eff WHIRLPOOL c9a0fbcba55864105496069289b78e33c66c62e8133df5bf631c99a296cc7295637cb4b43c63c783cbe8ca506c66394d09f5126da632afecf275cd30bb1d1e8a
EBUILD gitlab-git-http-server-0.2.9.ebuild 1292 SHA256 077476acd42ef3e344d01f162a17e5c329941af0b9b1456834bc8cceef6daa4e SHA512 63ec34875058709f529fdfcfb373f7b5fa24f499f77de6bd9ce6065a1ad26068a5e29e355b686c3ad08ca38e5e07fb688d8d8607d699c1a4a50105d87489d0e6 WHIRLPOOL 0ebac54a5e5de140ed8968bd3d9b3d84f7802193ed274672952a8b5cbfa0eeea2b58d460b6f7de647a3cf6da019a646d9ef3fe9b0d1e7efb20411284ea7d60ba

View File

@ -0,0 +1,12 @@
diff --git a/Makefile b/Makefile
index f6456e1..c25e29e 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
-PREFIX=/usr/local
-VERSION=$(shell git describe)-$(shell date -u +%Y%m%d.%H%M%S)
+PREFIX=${DESTDIR}/usr
+VERSION=0.2.9-$(shell date -u +%Y%m%d.%H%M%S)
gitlab-git-http-server: main.go githandler.go
go build -ldflags "-X main.Version ${VERSION}" -o gitlab-git-http-server

View File

@ -0,0 +1,10 @@
AUTH_BACKEND=http://localhost:8080
LISTEN_ADDR=localhost:8181
LISTEN_NETWORK=tcp
LISTEN_UMASK=022
PPROF_LISTEN_ADDRESS=
GIT_REPO_PATH=/var/lib/git/repositories
RUNAS_USER=gitlab_git_http_server
RUNAS_GROUP=${RUNAS_USER}

View File

@ -0,0 +1,9 @@
#!/sbin/runscript
start() {
ebegin "Starting gitlab-git-http-server"
start-stop-daemon --start --exec /usr/bin/gitlab-git-http-server --pidfile /run/gitlab-git-http-server.pid \
--make-pidfile --user ${RUNAS_USER}:${RUNAS_GROUP} \
-- -authBackend=${AUTH_BACKEND} -listenAddr=${LISTEN_ADDR} -listenNetwork=${LISTEN_NETWORK} -listenUmask=${LISTEN_UMASK} \
-pprofListenAddr=${PPROF_LISTEN_ADDR} ${GIT_REPO_PATH}
}

View File

@ -0,0 +1,60 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI="5"
inherit eutils user
DESCRIPTION="GitLab Git HTTP Server is the new backend for Git-over-HTTP communication needed for GitLab >= 8.0"
HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-git-http-server"
SRC_URI="https://gitlab.com/gitlab-org/${PN}/repository/archive.tar.bz2?ref=${PV} -> ${P}.tar.bz2"
S="${WORKDIR}/${P}-ffd46d3adeb1ebaf88eaedf4d4845834cfe8b385"
RESTRICT="mirror"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND="dev-vcs/git"
CDEPEND="dev-lang/go"
RDEPEND="${DEPEND}
net-libs/nodejs
virtual/mta"
MY_NAME="${PN}"
MY_USER="gitlab_git_http_server"
DEST_DIR="/opt/${MY_NAME}"
LOGS_DIR="/var/log/${MY_NAME}"
TEMP_DIR="/var/tmp/${MY_NAME}"
RUN_DIR="/run/${MY_NAME}"
#pkg_setup() {
#}
src_prepare() {
epatch "${FILESDIR}/fix-Makefile-${PV}.patch"
}
src_install() {
local dest=/usr/bin
diropts -m755
dodir ${dest}
exeinto ${dest}
doexe "${S}/${PN}"
# fix permissions
# fowners -R ${MY_USER}:${MY_USER} ${dest}
## RC script ##
newinitd "${FILESDIR}/gitlab-git-http-server.init" "${PN}"
newconfd "${FILESDIR}/gitlab-git-http-server.conf" "${PN}"
}
pkg_postinst() {
enewgroup ${MY_USER}
enewuser ${MY_USER} -1 -1 -1 ${MY_USER}
}