dev-go/go-bindata:

added ebuild for go-bindata, which is simply copied from the mrueg overlay, but references the forked go-bindata of fritteli that has a tag instead of referencing an arbitrary commit hash

Package-Manager: portage-2.3.0
This commit is contained in:
Manuel Friedli 2016-10-24 22:51:32 +02:00
parent becf75bd2b
commit 3f1df5a69b
5 changed files with 76 additions and 0 deletions

View File

@ -0,0 +1,7 @@
*go-bindata-3.0.8_alpha (24 Oct 2016)
24 Oct 2016; Manuel Friedli <manuel@fritteli.ch>
+files/0001-github-path.patch, +go-bindata-3.0.8_alpha.ebuild, +metadata.xml:
dev-go/go-bindata: added ebuild for go-bindata, which is simply copied from
the mrueg overlay, but references the forked go-bindata of fritteli that has a
tag instead of referencing an arbitrary commit hash

View File

@ -0,0 +1,5 @@
AUX 0001-github-path.patch 876 SHA256 668024c830d2459e963f113b556ac18eb7e66ca60c1d91623f6c5ef145352743 SHA512 c25eb5393d202c3b51316b8a7ed45bb37c27612f0849914851b74085e8a123dace9c0cbb694306c2eca05b3d2435ea4ef949d29d27e1ce82a6f6a1ccd80e9965 WHIRLPOOL 541673de305cc5c3d5fbb339ba325a616427218e83ca47db2e4d3ea5a4e8b57ac37fff4bb9e87d6e91245579fd28ee0f25e372752299557f8a969731b194e507
DIST go-bindata-3.0.8_alpha.tar.gz 17877 SHA256 59fa7f3cae0a06a140e118c899a043f15520f386f9472e800223e43a0f105a82 SHA512 d1ca839960eb3596d3003c56bf4d72ebb7a31992f6e0677448184e3c95b91bdbb7686ceea5bf132299965bf228c5b899d7ddce2ed3065909842b69282f541575 WHIRLPOOL e05734ce514a2b5a5cbeb5c3cd5952a2a1c9c6427ce2f337c2c518f624709008023475788fa1ea6fad69fe6d4909eb8652c9414f98f7a54834d494626a7aef6c
EBUILD go-bindata-3.0.8_alpha.ebuild 691 SHA256 25cf7c7b5127aad76848c26e16c2ae00582e1dbd55e98d1fe7c13bcd20401b7d SHA512 7fdf31f451cd50378904a1655712ae01bd2a73f1424936b4c4b1f583b1d65576b55263c81eb523a0c39f9b67d3121dd377de723a36660b311184379b413e8b17 WHIRLPOOL 119fa6a1d0cee23de8c7bb2d0fb738e67d3a72518e8b18df6a93aaa813c8605229c4d6a16553449d74f9e331e20601deb856dbc716363848ca440327667f6a33
MISC ChangeLog 384 SHA256 291af0a791a378ce112ca01f14ecc696e7f0565e0148f60a1346d895eac7a24b SHA512 1abe3ab1f226a2c03be509289d3c2f4e1d2be3334a70b85288a2f9f21f004102d0d8dc65325519ad2719b1919f1d302b2ecac44d4e256561b8b222a125ed5a05 WHIRLPOOL 39a13ef06a98a2477625a00269e5a8fb5f5749015a124eba0c388789f62eef63e66e15205e575cecf74cb63ba9407380a94fb7b1bcf82d351e9f68308e1d135e
MISC metadata.xml 248 SHA256 7b43be15755627edf5c12cf1b50c607d781558640bf8375d685d51d7ade99a32 SHA512 29f9b96b0a77546cce6a8bffd82fae2fd0939d32a7a05ffd0d91f9250a019a3ddaa599b93988c82daabb9c4c4b284dd947e2c47f6ca7727b8539cffa91bcb8c2 WHIRLPOOL 993013c9878ead35469db13d3072f694a341ee654182e0c31d0678f5dd6de4bdc8d59a0b7bb6d685dc41ea6b55dac518cd8034131baea8002170c680e50304d1

View File

@ -0,0 +1,26 @@
diff --git a/src/github.com/fritteli/go-bindata/README.md b/src/github.com/fritteli/go-bindata/README.md
index bca57f7..ea3a64f 100644
--- a/src/github.com/fritteli/go-bindata/README.md
+++ b/src/github.com/fritteli/go-bindata/README.md
@@ -13,7 +13,7 @@ output being generated.
To install the library and command line program, use the following:
- go get -u github.com/jteeuwen/go-bindata/...
+ go get -u github.com/fritteli/go-bindata/...
### Usage
diff --git a/src/github.com/fritteli/go-bindata/go-bindata/main.go b/src/github.com/fritteli/go-bindata/go-bindata/main.go
index 503a059..5513c99 100644
--- a/src/github.com/fritteli/go-bindata/go-bindata/main.go
+++ b/src/github.com/fritteli/go-bindata/go-bindata/main.go
@@ -12,7 +12,7 @@ import (
"regexp"
"strings"
- "github.com/jteeuwen/go-bindata"
+ "github.com/fritteli/go-bindata"
)
func main() {

View File

@ -0,0 +1,30 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
inherit eutils golang-build golang-vcs-snapshot
MY_PV="v${PV/_/-}"
EGO_PN="github.com/fritteli/${PN}/..."
EGIT_COMMIT="a0ff2567cfb70903282db057e799fd826784d41d"
ARCHIVE_URI="https://${EGO_PN%/*}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
DESCRIPTION="A small utility which generates Go code from any file"
HOMEPAGE="https://github.com/fritteli/${PN}"
SRC_URI="${ARCHIVE_URI}"
LICENSE="CC-PD"
SLOT="0/${PVR}"
IUSE=""
src_prepare() {
epatch "${FILESDIR}/0001-github-path.patch"
eapply_user
}
src_install() {
golang-build_src_install
dobin bin/*
}

View File

@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>manuel@fritteli.ch</email>
<name>Manuel Friedli</name>
</maintainer>
</pkgmetadata>