added ebuild for gitlab-git-http-server-0.3.0. no manifest yet, not testet yet, as gitlab.com is down and i can't download the binary :)
This commit is contained in:
parent
58880b6e21
commit
4c64a9d6bb
2 changed files with 49 additions and 0 deletions
|
@ -0,0 +1,12 @@
|
|||
diff --git a/Makefile b/Makefile
|
||||
index f6456e1..c25e29e 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1,5 +1,5 @@
|
||||
-PREFIX=/usr/local
|
||||
-VERSION=$(shell git describe)-$(shell date -u +%Y%m%d.%H%M%S)
|
||||
+PREFIX=${DESTDIR}/usr
|
||||
+VERSION=0.3.0-$(shell date -u +%Y%m%d.%H%M%S)
|
||||
|
||||
gitlab-git-http-server: main.go githandler.go
|
||||
go build -ldflags "-X main.Version ${VERSION}" -o gitlab-git-http-server
|
|
@ -0,0 +1,37 @@
|
|||
# Copyright 1999-2015 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI="5"
|
||||
|
||||
inherit eutils user
|
||||
|
||||
DESCRIPTION="GitLab Git HTTP Server is the new backend for Git-over-HTTP communication needed for GitLab >= 8.0"
|
||||
HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-git-http-server"
|
||||
SRC_URI="https://gitlab.com/gitlab-org/${PN}/repository/archive.tar.bz2?ref=${PV} -> ${P}.tar.bz2"
|
||||
S="${WORKDIR}/${P}-dda7c98adf850e032fa19c24173cbe567a416065"
|
||||
RESTRICT="mirror"
|
||||
|
||||
LICENSE="MIT"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
|
||||
DEPEND=">=dev-lang/go-1.5"
|
||||
|
||||
src_prepare() {
|
||||
epatch "${FILESDIR}/fix-Makefile-${PV}.patch"
|
||||
}
|
||||
|
||||
src_install() {
|
||||
local dest=/usr/bin
|
||||
|
||||
diropts -m755
|
||||
dodir ${dest}
|
||||
|
||||
exeinto ${dest}
|
||||
doexe "${S}/${PN}"
|
||||
|
||||
## RC script ##
|
||||
newinitd "${FILESDIR}/gitlab-git-http-server.init" "${PN}"
|
||||
newconfd "${FILESDIR}/gitlab-git-http-server.conf" "${PN}"
|
||||
}
|
Loading…
Reference in a new issue