added ebuild for dev-vcs/gitlab-workhorse-0.4.2

This commit is contained in:
Manuel Friedli 2015-11-23 10:01:06 +01:00
parent 3e3f92135e
commit 4c76aaa3f6
6 changed files with 95 additions and 0 deletions

View File

@ -0,0 +1,6 @@
AUX fix-Makefile-0.4.2.patch 508 SHA256 970bb7ce34fd846902ad83394e929f7162d3c33ddf8307f0538e1f3fb9d1b59f SHA512 77ef8cd1781a1dcd86483ec53db72ad31ea00556c96831f6f4af39c010a4075b503cf5c6a62c787139f92ab651f9a8fefecb8bdab6da38f9a139f89e96c15c86 WHIRLPOOL 33ee8956a2497f7a324f6970e3a8ec83ced3a2364593ce1272cc665c761f2d83a2ab6b73062a333216acb9d345108672181323c3228d94fd1630c29ef4c533e3
AUX gitlab-workhorse.conf 248 SHA256 6d11d63aa869cfd8c6f77c3a875984c226db633be899ad7ce97fafe94236eee7 SHA512 234213c8361702bdfeea40bd306b5899de19f34ce985e090a86e01aa601cf4ed23da4dfb75f74fe5986bbea5535a7a6a745406b4f67f79d352bd1c863777c7f1 WHIRLPOOL 8ac1134cde3aee942466d206e703ebd5330f83537d7e29641447f812d857bcc57b07fbf82eab086c0d622750694f64fabf8ffca2ba26a725f61b40fd1941e963
AUX gitlab-workhorse.init 653 SHA256 f38c37ed818cb8c25fb800bfcb5448f659e876b78ea33ea7a1ba3c80e73ea95e SHA512 2667997def39e6dc17e6a1d9be06d6e855d5d3e956e64d93bb3e74bbad0a1d427dc034f9c139f3b05e2666abab014404b2c8013c5347f4ec25fbf5ef86e7e88e WHIRLPOOL 63cd7ff80d88676b44c2d6ccdadf74907d5f8e4268f03ee11775c423bf95955f9d3aaeedd79fa6e0486b2d225336eb2ffa165dd7b9ac87ed0c2d403dc7e5afb4
DIST gitlab-workhorse-0.4.2.tar.bz2 14206 SHA256 09bd196334c2cde6e86a905df23ad904aaea7f01915b23c7e36cbff40fd0e14d SHA512 dcd2081786729ebcdd19aa1b5763a3ab4cf3e834ba0198827e354f610cbd338367229c2a57576413a3b18ab09a5fb1467eb0c9fe825830269a8990b662bce01a WHIRLPOOL 749803ad942e58e6dcf55dc4dcddf788591af7fe56729c946991e38c70f54aac65b3ba282e9a0106c9e717213ba70ba9c754257aee6bc5fedb3471eb333db4d6
EBUILD gitlab-workhorse-0.4.2.ebuild 878 SHA256 736ec8a77301e562545caebe75401dce1a5ab0ce9d27ca6d97e0029a088c3119 SHA512 099f0aaf00becd913f24db9cade200f987a1f9fb14f44d4290ad450f55ba50bbc3b7d5cc829072e371d0be98f0f000de96e5431a78ba0a62c287d6c3b256f6ce WHIRLPOOL b41e5570b35b6e4bda9509e25386db647bbff974a41c1a484cb6e7b65b67166fb31832b6b3edbdb2820da391a6836fae2ef692a13400939d7869598b2a89c8b7
MISC metadata.xml 234 SHA256 f35b97f99a26d73cc441e1d93bfe25aaa4e9f7f6d90c8d05a74f7b7bc5b68472 SHA512 59d8156b3ca3e99c40d5a2a32de7edf2eb53279b2424998862589d6bad77617d23fc852afec0a92f8ac5bb54a88ebc504cc0641029c1936412e90ab03dfdd447 WHIRLPOOL 935a1401910a42f888c991e443a49275ea8b87976c5aa977f670053d97d18754231749749bc92d37d4b5f45ecf65914480942a11b5827b6c08fb24313a428431

View File

@ -0,0 +1,16 @@
diff --git a/Makefile b/Makefile
index c2c8c59..419f4d8 100644
--- a/Makefile
+++ b/Makefile
@@ -1,8 +1,8 @@
-PREFIX=/usr/local
-VERSION=$(shell git describe)-$(shell date -u +%Y%m%d.%H%M%S)
+PREFIX=${DESTDIR}/usr
+VERSION=0.4.2-$(shell date -u +%Y%m%d.%H%M%S)
gitlab-workhorse: $(wildcard *.go)
- go build -ldflags "-X main.Version ${VERSION}" -o gitlab-workhorse
+ go build -ldflags "-X main.Version=${VERSION}" -o gitlab-workhorse
install: gitlab-workhorse
install gitlab-workhorse ${PREFIX}/bin/

View File

@ -0,0 +1,11 @@
AUTH_BACKEND=http://localhost:8080
LISTEN_ADDR=localhost:8181
LISTEN_NETWORK=tcp
LISTEN_UMASK=022
PPROF_LISTEN_ADDRESS=
GIT_REPO_PATH=/var/lib/git/repositories
RUNAS_USER=git
RUNAS_GROUP=${RUNAS_USER}
LOGFILE=/var/log/gitlab/gitlab-workhorse.log

View File

@ -0,0 +1,16 @@
#!/sbin/runscript
start() {
ebegin "Starting gitlab-workhorse"
start-stop-daemon --start --exec /usr/bin/gitlab-workhorse --pidfile /run/gitlab-workhorse.pid \
--make-pidfile --background --user ${RUNAS_USER}:${RUNAS_GROUP} --stdout "${LOGFILE}" --stderr "${LOGFILE}" \
-- -authBackend=${AUTH_BACKEND} -listenAddr=${LISTEN_ADDR} -listenNetwork=${LISTEN_NETWORK} -listenUmask=${LISTEN_UMASK} \
-pprofListenAddr=${PPROF_LISTEN_ADDR} ${GIT_REPO_PATH}
eend $?
}
stop() {
ebegin "Stopping gitlab-workhorse"
start-stop-daemon --stop --exec /usr/bin/gitlab-workhorse --pidfile /run/gitlab-workhorse.pid --user ${RUNAS_USER}:${RUNAS_GROUP}
eend $?
}

View File

@ -0,0 +1,38 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
inherit eutils user
DESCRIPTION="GitLab Workhorse is the new backend for Git-over-HTTP communication needed for GitLab >= 8.2"
HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-workhorse"
SRC_URI="https://gitlab.com/gitlab-org/${PN}/repository/archive.tar.bz2?ref=${PV} -> ${P}.tar.bz2"
S="${WORKDIR}/${P}-7a84085b1671f5d6b28408a83ff97a4ff3428b71"
RESTRICT="mirror"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND=">=dev-lang/go-1.5.1
!dev-vcs/gitlab-git-http-server"
src_prepare() {
epatch "${FILESDIR}/fix-Makefile-${PV}.patch"
}
src_install() {
local dest=/usr/bin
diropts -m755
dodir ${dest}
exeinto ${dest}
doexe "${S}/${PN}"
## RC script ##
newinitd "${FILESDIR}/${PN}.init" "${PN}"
newconfd "${FILESDIR}/${PN}.conf" "${PN}"
}

View File

@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
<email>manuel@fritteli.ch</email>
<name>Manuel Friedli</name>
</maintainer>
</pkgmetadata>