Version in official tree works perfectly.

This commit is contained in:
Manuel Friedli 2010-08-15 19:37:02 +00:00
parent 868c4e90f8
commit 76d9b983da
5 changed files with 0 additions and 246 deletions

View file

@ -1,5 +0,0 @@
AUX pyicq-t-0.8-initd 680 RMD160 0b8e2f2147615807abeb65a37c341b5c4035932f SHA1 0e78dcfde66fee25ff3a07040b16b478288f08ea SHA256 02f02bb3ed0aee4505a26e904d3fbef4e40f370f039a67289ec2dd1a194cef9c
AUX pyicq-t-0.8.1.5-hashlib.patch 3744 RMD160 63b232028a41a483d7fb00af46d62791bf29b319 SHA1 2ed1faa706c31c0e0485f5d7564f72da514bf5cf SHA256 ff177a0e9c6bafc57c7a4609f9ce1a8041def1c3ced3da9dd0f60fe86dde963f
AUX pyicq-t-0.8.1.5-initd 683 RMD160 ac70289702afcc6b84be54bd2ad2c30cf83915f1 SHA1 8d5f2177c9b0ff9e5c85ab812cd1a7844486b22a SHA256 813cd5653e2d1980f090a745b9ff81128d85e15e7ca1c989d6c0ccfad290bd9a
DIST pyicqt-0.8.1.5.tar.gz 183865 RMD160 205583d07d938a6d2d5b5af58d1a04682fd8318e SHA1 47606a4f84f6237c391a1c07139f8715913ea2ea SHA256 15ffa7b7d8f2d749492eec3b87bf64f8a429452282ca14e36ba5aee45b5322df
EBUILD pyicq-t-0.8.1.5-r1.ebuild 2250 RMD160 4c9efd80c3a5354093805f54177483e153cca40b SHA1 cc32c43bce45412d0bb68f53db9ab4b3a0e72068 SHA256 e85b899b78216af771e339d4740ddcec172189b1e7e3e99bc1c06ceaf394c503

View file

@ -1,23 +0,0 @@
#!/sbin/runscript
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/files/pyicq-t-0.8-initd,v 1.2 2007/06/04 20:50:16 griffon26 Exp $
depend() {
need net
use jabber-server
}
start() {
ebegin "Starting ICQ Jabber Transport"
start-stop-daemon --start --pidfile /var/run/jabber/pyicq-t.pid --chuid jabber:jabber \
--exec /usr/bin/python INSPATH/pyicq-t.py -- \
-b -c /etc/jabber/pyicq-t.xml -l /var/log/jabber/pyicq-t.log
eend $?
}
stop() {
ebegin "Stopping ICQ Jabber Transport"
start-stop-daemon --stop --quiet --pidfile /var/run/jabber/pyicq-t.pid
eend $?
}

View file

@ -1,120 +0,0 @@
diff -ru pyicqt-0.8.1.5-vanilla/src/avatar.py pyicqt-0.8.1.5/src/avatar.py
--- pyicqt-0.8.1.5-vanilla/src/avatar.py 2009-08-24 12:37:59.000000000 +0000
+++ pyicqt-0.8.1.5/src/avatar.py 2010-01-19 17:53:36.000000000 +0000
@@ -6,7 +6,7 @@
from twisted.words.xish.domish import Element
from debug import LogEvent, INFO, WARN, ERROR
import lang
-import sha
+import hashlib
import base64
import os
import os.path
@@ -46,7 +46,7 @@
class Avatar:
""" Represents an Avatar. Does not store the image in memory. """
def __init__(self, imageData, avatarCache):
- self.__imageHash = sha.sha(imageData).hexdigest()
+ self.__imageHash = hashlib.sha1(imageData).hexdigest()
self.__avatarCache = avatarCache
def getImageHash(self):
diff -ru pyicqt-0.8.1.5-vanilla/src/contact.py pyicqt-0.8.1.5/src/contact.py
--- pyicqt-0.8.1.5-vanilla/src/contact.py 2009-08-24 12:37:59.000000000 +0000
+++ pyicqt-0.8.1.5/src/contact.py 2010-01-19 17:52:43.000000000 +0000
@@ -8,7 +8,7 @@
import config
from debug import LogEvent, INFO, WARN, ERROR
import lang
-import sha
+import hashlib
import legacy
import globals
import base64
diff -ru pyicqt-0.8.1.5-vanilla/src/legacy/buddies.py pyicqt-0.8.1.5/src/legacy/buddies.py
--- pyicqt-0.8.1.5-vanilla/src/legacy/buddies.py 2009-08-24 12:37:59.000000000 +0000
+++ pyicqt-0.8.1.5/src/legacy/buddies.py 2010-01-19 17:49:24.000000000 +0000
@@ -12,7 +12,7 @@
import os.path
import binascii
import os.path
-import md5
+import hashlib
X = os.path.sep
@@ -188,7 +188,7 @@
avatarData = avatar.AvatarCache().setAvatar(imgmanip.convertToPNG(iconData))
c.updateAvatar(avatarData, push=True)
if not md5Hash:
- m = md5.new()
+ m = hashlib.md5()
m.update(iconData)
md5Hash = m.digest()
if not numHash:
diff -ru pyicqt-0.8.1.5-vanilla/src/legacy/glue.py pyicqt-0.8.1.5/src/legacy/glue.py
--- pyicqt-0.8.1.5-vanilla/src/legacy/glue.py 2009-08-24 12:37:59.000000000 +0000
+++ pyicqt-0.8.1.5/src/legacy/glue.py 2010-01-19 17:49:44.000000000 +0000
@@ -18,7 +18,7 @@
import time
import binascii
import avatar
-import md5
+import hashlib
import random
from twisted.python import log
@@ -398,7 +398,7 @@
try:
self.myavatar = imgmanip.convertToJPG(imageData)
self.myavatarlen = len(self.myavatar)
- m=md5.new()
+ m=hashlib.md5()
m.update(self.myavatar)
self.myavatarsum = m.digest()
self.myavatarstamp = time.time()
diff -ru pyicqt-0.8.1.5-vanilla/src/legacy/icqt.py pyicqt-0.8.1.5/src/legacy/icqt.py
--- pyicqt-0.8.1.5-vanilla/src/legacy/icqt.py 2009-08-24 12:37:59.000000000 +0000
+++ pyicqt-0.8.1.5/src/legacy/icqt.py 2010-01-19 17:50:22.000000000 +0000
@@ -14,7 +14,7 @@
import time
import datetime
import binascii
-import md5
+import hashlib
import locale
import struct
diff -ru pyicqt-0.8.1.5-vanilla/src/tlib/oscar.py pyicqt-0.8.1.5/src/tlib/oscar.py
--- pyicqt-0.8.1.5-vanilla/src/tlib/oscar.py 2009-08-24 12:37:59.000000000 +0000
+++ pyicqt-0.8.1.5/src/tlib/oscar.py 2010-01-19 17:48:01.000000000 +0000
@@ -21,7 +21,7 @@
from scheduler import Scheduler
import struct
-import md5
+import hashlib
import string
import socket
import random
@@ -120,9 +120,9 @@
return dict,data
def encryptPasswordMD5(password,key):
- m=md5.new()
+ m=hashlib.md5()
m.update(key)
- m.update(md5.new(password).digest())
+ m.update(hashlib.md5(password).digest())
m.update("AOL Instant Messenger (SM)")
return m.digest()
@@ -534,7 +534,7 @@
self.iconSum = tlvs.get(0xd5,"")
def updateIcon(self, iconData):
- m=md5.new()
+ m=hashlib.md5()
m.update(iconData)
self.iconSum = m.digest()
log.msg("icon sum is %s" % binascii.hexlify(self.iconSum))

View file

@ -1,23 +0,0 @@
#!/sbin/runscript
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/files/pyicq-t-0.8-initd,v 1.2 2007/06/04 20:50:16 griffon26 Exp $
depend() {
need net
use jabber-server
}
start() {
ebegin "Starting ICQ Jabber Transport"
start-stop-daemon --start --pidfile /var/run/jabber/pyicq-t.pid --chuid jabber:jabber \
--exec /usr/bin/python2.6 INSPATH/pyicq-t.py -- \
-b -c /etc/jabber/pyicq-t.xml -l /var/log/jabber/pyicq-t.log
eend $?
}
stop() {
ebegin "Stopping ICQ Jabber Transport"
start-stop-daemon --stop --quiet --pidfile /var/run/jabber/pyicq-t.pid
eend $?
}

View file

@ -1,75 +0,0 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/pyicq-t-0.8.1.5.ebuild,v 1.2 2009/10/03 17:30:43 maekke Exp $
NEED_PYTHON=2.6
inherit eutils multilib python
MY_P="${P/pyicq-t/pyicqt}"
DESCRIPTION="Python based jabber transport for ICQ"
HOMEPAGE="http://code.google.com/p/pyicqt/"
SRC_URI="http://pyicqt.googlecode.com/files/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="webinterface"
DEPEND="net-im/jabber-base"
RDEPEND="${DEPEND}
>=dev-python/twisted-9.0.0
>=dev-python/twisted-words-9.0.0
>=dev-python/twisted-web-9.0.0
webinterface? ( >=dev-python/nevow-0.4.1 )
>=dev-python/imaging-1.1"
src_unpack() {
epatch "${FILESDIR}/${P}-hashlib.patch"
}
src_install() {
local inspath
python_version
inspath=/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
insinto ${inspath}
doins -r data src tools
newins PyICQt.py ${PN}.py
insinto /etc/jabber
newins config_example.xml ${PN}.xml
fperms 600 /etc/jabber/${PN}.xml
fowners jabber:jabber /etc/jabber/${PN}.xml
dosed \
"s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
/etc/jabber/${PN}.xml
dosed \
"s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
/etc/jabber/${PN}.xml
newinitd "${FILESDIR}/${P}-initd" ${PN}
dosed "s:INSPATH:${inspath}:" /etc/init.d/${PN}
}
pkg_postinst() {
python_version
python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
elog "A sample configuration file has been installed in /etc/jabber/${PN}.xml."
elog "Please edit it and the configuration of your Jabber server to match."
ewarn "If you are storing user accounts in MySQL and are upgrading from a "
ewarn "version older than 0.8.1, then you will need to run the following "
ewarn "command to create some new tables:"
ewarn " mysql -u user_name -p pyicqt < /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}/tools/db-setup.mysql"
elog "These instructions along with a list of new config variables are "
elog "available at: http://code.google.com/p/pyicqt/wiki/Upgrade"
}
pkg_postrm() {
python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/${PN}
}