cleaned up old stuff.
This commit is contained in:
parent
4cfdef3aaa
commit
8bce5a5a22
4 changed files with 0 additions and 167 deletions
|
@ -1,9 +1,4 @@
|
|||
AUX palaver-confd 68 RMD160 7d751dd4d56f67c7c4dc0c6982bde8f89713cbc6 SHA1 7306ca4cd126d671b7c410a0a86733a0865d5f90 SHA256 b7bdd39f471c50505740e8aa1f217b93e7a3d2e849315c1a1533adf3db5d1929
|
||||
AUX palaver-initd 583 RMD160 466affc1d46da7781bf83617b626fc9fbcee2b81 SHA1 6787179201044cf2aecc9f093ac1662cd963c1ab SHA256 ef3e5972934ff8cda9d6652f0f54a32b5383e03f0cfb8f77dd58798762a12e01
|
||||
AUX palaver.py.diff 1579 RMD160 e3193dc2479673cecd788a5273d154340f572695 SHA1 951ccdef9de37a73e641989002e9a027695e0af7 SHA256 7b4a2b7fd95c4ded96cf9d7d4878365d8d47eba74835f5c13fab18f66ed548fa
|
||||
AUX palaver_plugin.py 1222 RMD160 33567d8968f2e1b44ecd1a2f0de08961083d5233 SHA1 a007343655eac579d01b50ea2b585bd26caceb26 SHA256 f9e81c27fb210799739ed36964b203a3ebde15584f9499d965db20e63eeeddf0
|
||||
DIST master 137185 RMD160 28ceb8a30d861e339fd397d8e652f41d967e2e86 SHA1 b005d6c13418c77845b08bf50c30b401729827c7 SHA256 db0a6b432c4570b37e58bba6ce466547c39f8380073b6917f7bca74b71e0db4a
|
||||
DIST palaver-0.6.tar.bz2 71431 RMD160 d1eac261b4ea9263d6992d17d5498f27b054643b SHA1 6e33a77322a432f5c20e6b05dea93ee10d6e4d5d SHA256 437a32250f7ba2a7b07e1dae894893ae4bf32e8a7d8d8e97a4803c9fee4dde26
|
||||
EBUILD palaver-0.6-r3.ebuild 1428 RMD160 43c5bae7622184f957d39f06d5ddc8949525a141 SHA1 2e5208f49fba67b42a04cb857f1e8e63627ac6f5 SHA256 177b114e9b224b220c925a2d25db72a6903fc288e884f757dea8648795b1b09d
|
||||
EBUILD palaver-0.6-r4.ebuild 1507 RMD160 98d01b524a5e1978700c6044bccca31eb4314539 SHA1 96f436ade61ba3f77253a3199ef1cdc59e125a60 SHA256 29d31475413a23f12caf6a2e88f5237202a1405672218d472ef1b8548b6667a1
|
||||
EBUILD palaver-9999.ebuild 1289 RMD160 dc18a2592621452b6098784efca86655a50381ac SHA1 ba39900a760e75823584bff666b235d5d3fa0ff6 SHA256 6d6aa2a1225add0259892a783e7746783ac8f62058d86614968e7a867484d561
|
||||
|
|
|
@ -1,50 +0,0 @@
|
|||
--- palaver.py 2012-03-19 11:44:46.000000000 +0100
|
||||
+++ palaver_plugin.py 2012-07-19 03:53:27.782461489 +0200
|
||||
@@ -1,7 +1,40 @@
|
||||
-from twisted.scripts.mktap import _tapHelper
|
||||
-
|
||||
-Palaver = _tapHelper(
|
||||
- "Palaver",
|
||||
- "palaver.tap",
|
||||
- "A multi-user chat xmpp/jabber component.",
|
||||
- "palaver")
|
||||
+from zope.interface import implements
|
||||
+from twisted.python import usage
|
||||
+from twisted.plugin import IPlugin
|
||||
+from twisted.application.service import IServiceMaker
|
||||
+
|
||||
+# Due to the directory layout, and the fact that plugin directories aren't
|
||||
+# modules (no __init__.py), this file is named something other than palaver.py,
|
||||
+# to ensure that this import pulls in the right module.
|
||||
+import palaver
|
||||
+
|
||||
+class Options(usage.Options):
|
||||
+ optParameters = [
|
||||
+ ('rhost', None, None),
|
||||
+ ('rport', None, None),
|
||||
+ ('secret', None, None),
|
||||
+ ('backend', None, 'dir'),
|
||||
+ ('spool', None, None),
|
||||
+ ('admin', None, 1),
|
||||
+ ('create', None, 1),
|
||||
+ ('dbname', None, 'muc'),
|
||||
+ ('dbuser', None, 'muc'),
|
||||
+ ('dbhostname', None, None),
|
||||
+ ('log', 'l', './html/logs/'),
|
||||
+ ('config', 'c', 'config.xml')
|
||||
+ ]
|
||||
+
|
||||
+ optFlags = [
|
||||
+ ('verbose', 'v', 'Show traffic'),
|
||||
+ ]
|
||||
+
|
||||
+class ServiceFactory(object):
|
||||
+ implements(IServiceMaker, IPlugin)
|
||||
+ tapname = "palaver"
|
||||
+ description = "A multi-user chat xmpp/jabber component."
|
||||
+ options = Options
|
||||
+
|
||||
+ def makeService(self, options):
|
||||
+ return palaver.makeService(options)
|
||||
+
|
||||
+service = ServiceFactory()
|
|
@ -1,55 +0,0 @@
|
|||
# Copyright 1999-2008 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: $
|
||||
|
||||
PYTHON_DEPEND="2"
|
||||
|
||||
inherit eutils python
|
||||
DESCRIPTION="Multi-user chat component for jabber implemented in python"
|
||||
HOMEPAGE="http://code.stanziq.com/palaver"
|
||||
SRC_URI="http://code.stanziq.com/cgit/${PN}/${PN}/snapshot/${P}.tar.bz2"
|
||||
LICENSE="MIT"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE=""
|
||||
DEPEND="net-im/jabber-base"
|
||||
RDEPEND=">=dev-python/twisted-2.4.0
|
||||
>=dev-python/twisted-words-0.5
|
||||
${DEPEND}"
|
||||
|
||||
src_unpack() {
|
||||
unpack ${A} && cd "${S}" || die "unpack failed"
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
# nothing to be done here?
|
||||
distutils_src_compile
|
||||
}
|
||||
|
||||
src_install() {
|
||||
distutils_src_install
|
||||
|
||||
insinto /etc/jabber
|
||||
newins example-config.xml ${PN}.xml
|
||||
fperms 600 /etc/jabber/${PN}.xml
|
||||
fowners jabber:jabber /etc/jabber/${PN}.xml
|
||||
dosed \
|
||||
"s:<spool>[^\<]*</spool>:<spool>/var/spool/jabber</spool>:" \
|
||||
/etc/jabber/${PN}.xml
|
||||
|
||||
# dosed \
|
||||
# "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
|
||||
# /etc/jabber/${PN}.xml
|
||||
|
||||
newinitd "${FILESDIR}/${PN}-initd" ${PN}
|
||||
# dosed "s:INSPATH:${inspath}:" /etc/init.d/${PN}
|
||||
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
einfo "A sample config file has been installed into /etc/jabber/${PN}.xml."
|
||||
einfo "Please adjust the settings as needed."
|
||||
einfo "After that, you MUST create a TAP-file for twisted in order to start Palaver, like this:"
|
||||
einfo "# cd /etc/jabber"
|
||||
einfo "# mktap palaver -c palaver.xml"
|
||||
}
|
|
@ -1,57 +0,0 @@
|
|||
# Copyright 1999-2008 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: $
|
||||
|
||||
PYTHON_DEPEND="2"
|
||||
|
||||
inherit eutils python
|
||||
DESCRIPTION="Multi-user chat component for jabber implemented in python"
|
||||
HOMEPAGE="https://github.com/twonds/palaver"
|
||||
MY_PN="master"
|
||||
SRC_URI="https://github.com/twonds/palaver/tarball/${MY_PN}"
|
||||
#SRC_URI="http://code.stanziq.com/cgit/${PN}/${PN}/snapshot/${P}.tar.bz2"
|
||||
LICENSE="MIT"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE=""
|
||||
DEPEND="net-im/jabber-base"
|
||||
RDEPEND=">=dev-python/twisted-2.4.0
|
||||
>=dev-python/twisted-words-0.5
|
||||
${DEPEND}"
|
||||
|
||||
src_unpack() {
|
||||
unpack ${A} && cd "${S}" || die "unpack failed"
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
# nothing to be done here?
|
||||
distutils_src_compile
|
||||
}
|
||||
|
||||
src_install() {
|
||||
distutils_src_install
|
||||
|
||||
insinto /etc/jabber
|
||||
newins example-config.xml ${PN}.xml
|
||||
fperms 600 /etc/jabber/${PN}.xml
|
||||
fowners jabber:jabber /etc/jabber/${PN}.xml
|
||||
dosed \
|
||||
"s:<spool>[^\<]*</spool>:<spool>/var/spool/jabber</spool>:" \
|
||||
/etc/jabber/${PN}.xml
|
||||
|
||||
# dosed \
|
||||
# "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
|
||||
# /etc/jabber/${PN}.xml
|
||||
|
||||
newinitd "${FILESDIR}/${PN}-initd" ${PN}
|
||||
# dosed "s:INSPATH:${inspath}:" /etc/init.d/${PN}
|
||||
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
einfo "A sample config file has been installed into /etc/jabber/${PN}.xml."
|
||||
einfo "Please adjust the settings as needed."
|
||||
einfo "After that, you MUST create a TAP-file for twisted in order to start Palaver, like this:"
|
||||
einfo "# cd /etc/jabber"
|
||||
einfo "# mktap palaver -c palaver.xml"
|
||||
}
|
Loading…
Reference in a new issue