added garmintools
This commit is contained in:
parent
00823c0200
commit
91ee9a75f1
4 changed files with 108 additions and 0 deletions
5
sci-geosciences/garmintools/Manifest
Normal file
5
sci-geosciences/garmintools/Manifest
Normal file
|
@ -0,0 +1,5 @@
|
||||||
|
AUX garmintools-005-r1-add-xml-root.patch 419 RMD160 59a14e10c34c698bc31cdf68f32fab22d455c2eb SHA1 f743850854f2d3da42844c238719d9261505f031 SHA256 58802fbddf121cc9c2236fac5220895248854e438bee2e43a35b2129ffa7f7a2
|
||||||
|
DIST garmintools-0.05.tar.gz 377015 RMD160 fb0148defa4a19d839baecab783eece40e197de9 SHA1 8c5da0e9b00305639b64d221e67eabd5792b2445 SHA256 d3a293ea64a26c660c7f8e9f24741ff5986fc114876974744900402fb2ae1a3b
|
||||||
|
DIST garmintools-0.10.tar.gz 396659 RMD160 307cd9bc99288c2305324c05792022c457ef5e5d SHA1 f59a761b09575d27abbf5d76811f7ec25a1cbd26 SHA256 ffd50b7f963fa9b8ded3223c4786b07906c887ed900de64581a24ff201444cee
|
||||||
|
EBUILD garmintools-0.05-r1.ebuild 855 RMD160 afb42eb05b0b137d0eb762f607f2343250c03f4a SHA1 27bf41ff3eeaed3fc3211468f9b96d154f0c86f2 SHA256 47de01f1cb433d7a4158ac1e584399a2f45ee8c492b0a2f64c71f119d53c578a
|
||||||
|
EBUILD garmintools-0.10.ebuild 856 RMD160 32513499d402d3005983f6ce919b42fb24a91289 SHA1 5a08baa363ffabcdaedff9e57b837bcc3fa5b26a SHA256 318082bd529e10156b442962f96d992b2144e4ba81d08b67587aaf34ac1a48ab
|
|
@ -0,0 +1,17 @@
|
||||||
|
--- src/garmin_dump.c~ 2007-07-20 13:59:04.000000000 -0400
|
||||||
|
+++ src/garmin_dump.c 2007-08-27 21:02:04.000000000 -0400
|
||||||
|
@@ -9,12 +9,14 @@
|
||||||
|
garmin_data * data;
|
||||||
|
int i;
|
||||||
|
|
||||||
|
+ printf("<data>\n");
|
||||||
|
for ( i = 1; i < argc; i++ ) {
|
||||||
|
if ( (data = garmin_load(argv[i])) != NULL ) {
|
||||||
|
garmin_print_data(data,stdout,0);
|
||||||
|
garmin_free_data(data);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
+ printf("</data>\n");
|
||||||
|
|
||||||
|
return 0;
|
||||||
|
}
|
43
sci-geosciences/garmintools/garmintools-0.05-r1.ebuild
Normal file
43
sci-geosciences/garmintools/garmintools-0.05-r1.ebuild
Normal file
|
@ -0,0 +1,43 @@
|
||||||
|
# Copyright 1999-2007 Gentoo Foundation
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsbabel/gpsbabel-1.3.3.ebuild,v 1.3 2007/07/18 02:02:04 cryos Exp $
|
||||||
|
|
||||||
|
inherit eutils
|
||||||
|
|
||||||
|
DESCRIPTION="A Linux interface to the Garmin Forerunner GPS units"
|
||||||
|
|
||||||
|
HOMEPAGE="http://code.google.com/p/garmintools/"
|
||||||
|
|
||||||
|
SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
|
||||||
|
|
||||||
|
LICENSE="GPL-2"
|
||||||
|
|
||||||
|
SLOT="0"
|
||||||
|
|
||||||
|
KEYWORDS="x86"
|
||||||
|
|
||||||
|
IUSE="usb"
|
||||||
|
|
||||||
|
RDEPEND="usb? ( dev-libs/libusb )"
|
||||||
|
|
||||||
|
DEPEND="${RDEPEND}"
|
||||||
|
|
||||||
|
src_unpack(){
|
||||||
|
unpack ${A}
|
||||||
|
cd "${S}"
|
||||||
|
epatch "${FILESDIR}"/${PF}-add-xml-root.patch || die "Unable to apply ${PF}-add-xml-root.patch"
|
||||||
|
}
|
||||||
|
|
||||||
|
src_compile() {
|
||||||
|
local myconf="";
|
||||||
|
econf ${myconf}
|
||||||
|
emake || die "emake failed"
|
||||||
|
}
|
||||||
|
|
||||||
|
src_install() {
|
||||||
|
cd "${S}"
|
||||||
|
make DESTDIR="${D}" install || die "Install failed"
|
||||||
|
}
|
||||||
|
|
||||||
|
#pkg_postinst(){
|
||||||
|
#}
|
43
sci-geosciences/garmintools/garmintools-0.10.ebuild
Normal file
43
sci-geosciences/garmintools/garmintools-0.10.ebuild
Normal file
|
@ -0,0 +1,43 @@
|
||||||
|
# Copyright 1999-2007 Gentoo Foundation
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsbabel/gpsbabel-1.3.3.ebuild,v 1.3 2007/07/18 02:02:04 cryos Exp $
|
||||||
|
|
||||||
|
inherit eutils
|
||||||
|
|
||||||
|
DESCRIPTION="A Linux interface to the Garmin Forerunner GPS units"
|
||||||
|
|
||||||
|
HOMEPAGE="http://code.google.com/p/garmintools/"
|
||||||
|
|
||||||
|
SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
|
||||||
|
|
||||||
|
LICENSE="GPL-2"
|
||||||
|
|
||||||
|
SLOT="0"
|
||||||
|
|
||||||
|
KEYWORDS="x86"
|
||||||
|
|
||||||
|
IUSE="usb"
|
||||||
|
|
||||||
|
RDEPEND="usb? ( dev-libs/libusb )"
|
||||||
|
|
||||||
|
DEPEND="${RDEPEND}"
|
||||||
|
|
||||||
|
src_unpack(){
|
||||||
|
unpack ${A}
|
||||||
|
cd "${S}"
|
||||||
|
# epatch "${FILESDIR}"/${PF}-add-xml-root.patch || die "Unable to apply ${PF}-add-xml-root.patch"
|
||||||
|
}
|
||||||
|
|
||||||
|
src_compile() {
|
||||||
|
local myconf="";
|
||||||
|
econf ${myconf}
|
||||||
|
emake || die "emake failed"
|
||||||
|
}
|
||||||
|
|
||||||
|
src_install() {
|
||||||
|
cd "${S}"
|
||||||
|
make DESTDIR="${D}" install || die "Install failed"
|
||||||
|
}
|
||||||
|
|
||||||
|
#pkg_postinst(){
|
||||||
|
#}
|
Loading…
Reference in a new issue