added my own ebuild for evince, which depends on virtual/texbase instead of virtual/tetex
This commit is contained in:
parent
e792042f9a
commit
d8df06edbc
6 changed files with 143 additions and 0 deletions
20
app-text/evince/Manifest
Normal file
20
app-text/evince/Manifest
Normal file
|
@ -0,0 +1,20 @@
|
|||
AUX evince-0.5.3-display-menu.patch 460 RMD160 8c72adb3a9a7105518eb9d1f686c4a96f1467f96 SHA1 c0a71996202fe85e3e3554fdc7e9a37cf0d3b795 SHA256 b9355d24321352e294170b86110019b47e26de80bd7f7c626eab582d35d5b46e
|
||||
MD5 42ae4caf217262666d8e46b484e0ee0c files/evince-0.5.3-display-menu.patch 460
|
||||
RMD160 8c72adb3a9a7105518eb9d1f686c4a96f1467f96 files/evince-0.5.3-display-menu.patch 460
|
||||
SHA256 b9355d24321352e294170b86110019b47e26de80bd7f7c626eab582d35d5b46e files/evince-0.5.3-display-menu.patch 460
|
||||
AUX evince-0.6.1-dbus-switch.patch 974 RMD160 85726bcd9000ebde631d8102a0f79aa6d6df8de1 SHA1 246f5c18ba30de97922af003757283179134c7bf SHA256 1fe375cf561b215a9d25482b7e74ee254cf3f052a7a77a7ac7b71fa0e872fd49
|
||||
MD5 0ae3972c36cf8a8e09566e710c40c4bc files/evince-0.6.1-dbus-switch.patch 974
|
||||
RMD160 85726bcd9000ebde631d8102a0f79aa6d6df8de1 files/evince-0.6.1-dbus-switch.patch 974
|
||||
SHA256 1fe375cf561b215a9d25482b7e74ee254cf3f052a7a77a7ac7b71fa0e872fd49 files/evince-0.6.1-dbus-switch.patch 974
|
||||
AUX evince-0.7.1-display-menu.patch 476 RMD160 a16a5e1f32490a7db219442b23cbcf77773e6bdd SHA1 73a97e83b12ad80f6645339978717bcf8c7da575 SHA256 1f450dfe57ef3325cb4642141d76fc8e7bf837c221d81a2593214913af058f4d
|
||||
MD5 f6a0bf60c1923dd3d3ed97f685c66a3a files/evince-0.7.1-display-menu.patch 476
|
||||
RMD160 a16a5e1f32490a7db219442b23cbcf77773e6bdd files/evince-0.7.1-display-menu.patch 476
|
||||
SHA256 1f450dfe57ef3325cb4642141d76fc8e7bf837c221d81a2593214913af058f4d files/evince-0.7.1-display-menu.patch 476
|
||||
DIST evince-2.20.2.tar.bz2 1614179 RMD160 25daf214a29a2ead7161574852fd89c5bb6a848b SHA1 9d8d847314d728e579009eae76f2a84e17c9c893 SHA256 c6e9f2d8a90f95bc235b21ffb5be0d183ce2bfaaea84a4eafdb2449a2349129c
|
||||
EBUILD evince-2.20.2.ebuild 1979 RMD160 25814f14d24c2c2acff9e6c3d368e8542c2713f9 SHA1 caea820dd875a0cad7c8186372d603edd434dae7 SHA256 089013c8519c276ad40436248bfeb0967d7529902537681e34851a0479b42c48
|
||||
MD5 0841dadcab8810e39bb87681e6470b4f evince-2.20.2.ebuild 1979
|
||||
RMD160 25814f14d24c2c2acff9e6c3d368e8542c2713f9 evince-2.20.2.ebuild 1979
|
||||
SHA256 089013c8519c276ad40436248bfeb0967d7529902537681e34851a0479b42c48 evince-2.20.2.ebuild 1979
|
||||
MD5 514275d1db727ffc21ecda7df163f96d files/digest-evince-2.20.2 247
|
||||
RMD160 c87199944c546ed515b24e8318fad2911d7e06a7 files/digest-evince-2.20.2 247
|
||||
SHA256 e0c3ef6676ae522287c5432beb1b5bf4407e3684098d2b3847aff12552d00b17 files/digest-evince-2.20.2 247
|
77
app-text/evince/evince-2.20.2.ebuild
Normal file
77
app-text/evince/evince-2.20.2.ebuild
Normal file
|
@ -0,0 +1,77 @@
|
|||
# Copyright 1999-2008 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-2.20.2.ebuild,v 1.7 2008/02/04 04:00:45 jer Exp $
|
||||
|
||||
WANT_AUTOMAKE="1.9"
|
||||
inherit eutils gnome2 autotools
|
||||
|
||||
DESCRIPTION="Simple document viewer for GNOME"
|
||||
HOMEPAGE="http://www.gnome.org/projects/evince/"
|
||||
|
||||
LICENSE="GPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd"
|
||||
IUSE="dbus djvu doc dvi gnome t1lib tiff"
|
||||
|
||||
RDEPEND="
|
||||
dbus? ( >=dev-libs/dbus-glib-0.71 )
|
||||
>=x11-libs/gtk+-2.10
|
||||
gnome-base/gnome-keyring
|
||||
>=gnome-base/libgnomeui-2.14
|
||||
>=gnome-base/libgnome-2.14
|
||||
dev-libs/libxml2
|
||||
>=x11-themes/gnome-icon-theme-2.17.1
|
||||
>=gnome-base/gnome-vfs-2.0
|
||||
>=gnome-base/libglade-2
|
||||
>=dev-libs/glib-2
|
||||
gnome? ( >=gnome-base/nautilus-2.10 )
|
||||
>=app-text/poppler-bindings-0.6
|
||||
dvi? (
|
||||
virtual/tex-base
|
||||
t1lib? ( >=media-libs/t1lib-5.0.0 )
|
||||
)
|
||||
tiff? ( >=media-libs/tiff-3.6 )
|
||||
>=gnome-base/gconf-2
|
||||
djvu? ( >=app-text/djvu-3.5.17 )
|
||||
virtual/ghostscript"
|
||||
|
||||
DEPEND="${RDEPEND}
|
||||
app-text/scrollkeeper
|
||||
>=app-text/gnome-doc-utils-0.3.2
|
||||
>=dev-util/pkgconfig-0.9
|
||||
>=sys-devel/automake-1.9
|
||||
>=dev-util/intltool-0.35"
|
||||
|
||||
DOCS="AUTHORS ChangeLog NEWS README TODO"
|
||||
ELTCONF="--portage"
|
||||
RESTRICT="test"
|
||||
|
||||
pkg_setup() {
|
||||
G2CONF="--disable-scrollkeeper \
|
||||
--enable-comics \
|
||||
--enable-impress \
|
||||
$(use_enable dbus) \
|
||||
$(use_enable djvu) \
|
||||
$(use_enable dvi) \
|
||||
$(use_enable t1lib) \
|
||||
$(use_enable tiff) \
|
||||
$(use_enable gnome nautilus)"
|
||||
|
||||
if ! built_with_use app-text/poppler-bindings gtk; then
|
||||
einfo "Please re-emerge app-text/poppler-bindings with the gtk USE flag set"
|
||||
die "poppler-bindings needs gtk flag set"
|
||||
fi
|
||||
}
|
||||
|
||||
src_unpack() {
|
||||
gnome2_src_unpack
|
||||
|
||||
# Fix .desktop file so menu item shows up
|
||||
epatch "${FILESDIR}"/${PN}-0.7.1-display-menu.patch
|
||||
|
||||
# Make dbus actually switchable
|
||||
epatch "${FILESDIR}"/${PN}-0.6.1-dbus-switch.patch
|
||||
|
||||
cp aclocal.m4 old_macros.m4
|
||||
AT_M4DIR="." eautoreconf
|
||||
}
|
3
app-text/evince/files/digest-evince-2.20.2
Normal file
3
app-text/evince/files/digest-evince-2.20.2
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 15214f5211d9f98ffa0afd8158b7d021 evince-2.20.2.tar.bz2 1614179
|
||||
RMD160 25daf214a29a2ead7161574852fd89c5bb6a848b evince-2.20.2.tar.bz2 1614179
|
||||
SHA256 c6e9f2d8a90f95bc235b21ffb5be0d183ce2bfaaea84a4eafdb2449a2349129c evince-2.20.2.tar.bz2 1614179
|
11
app-text/evince/files/evince-0.5.3-display-menu.patch
Normal file
11
app-text/evince/files/evince-0.5.3-display-menu.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
diff --exclude-from=/home/dang/.diffrc -u -ruN evince-0.5.3.orig/data/evince.desktop.in.in evince-0.5.3/data/evince.desktop.in.in
|
||||
--- evince-0.5.3.orig/data/evince.desktop.in.in 2006-05-06 17:52:05.000000000 -0400
|
||||
+++ evince-0.5.3/data/evince.desktop.in.in 2006-05-16 11:35:54.000000000 -0400
|
||||
@@ -9,7 +9,6 @@
|
||||
Terminal=false
|
||||
Type=Application
|
||||
Icon=evince.png
|
||||
-NoDisplay=true
|
||||
X-GNOME-DocPath=
|
||||
X-GNOME-Bugzilla-Bugzilla=GNOME
|
||||
X-GNOME-Bugzilla-Product=evince
|
21
app-text/evince/files/evince-0.6.1-dbus-switch.patch
Normal file
21
app-text/evince/files/evince-0.6.1-dbus-switch.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
diff --exclude-from=/home/dang/.diffrc -up -ruN evince-0.6.1.orig/configure.ac evince-0.6.1/configure.ac
|
||||
--- evince-0.6.1.orig/configure.ac 2006-10-09 14:58:09.000000000 -0400
|
||||
+++ evince-0.6.1/configure.ac 2006-12-17 11:41:10.000000000 -0500
|
||||
@@ -109,6 +109,9 @@ AM_CONDITIONAL(WITH_GTK_PRINT, test x$en
|
||||
|
||||
|
||||
dnl ========= Check for DBUS
|
||||
+AC_ARG_ENABLE(dbus,
|
||||
+ [AC_HELP_STRING([--enable-dbus], [Compile with support for dbus])],enable_dbus="$enableval",enable_dbus=yes)
|
||||
+if test "x$enable_dbus" != "xno"; then
|
||||
PKG_CHECK_MODULES([DBUS], [dbus-glib-1 >= $DBUS_GLIB_REQUIRED],
|
||||
[enable_dbus=yes],[enable_dbus=no])
|
||||
AC_SUBST([DBUS_CFLAGS])
|
||||
@@ -130,6 +133,7 @@ if test "x$enable_dbus" = "xyes" ; then
|
||||
DBUS_VERSION=`$PKG_CONFIG --modversion dbus-glib-1 | sed 's/0\.\([[0-9]]*\)\.\{0,1\}\([[0-9]]*\)/\1/'`
|
||||
AC_DEFINE_UNQUOTED(DBUS_VERSION, $DBUS_VERSION, [DBUS version.])
|
||||
fi
|
||||
+fi
|
||||
|
||||
SHELL_CFLAGS="$SHELL_CORE_CFLAGS $DBUS_CFLAGS"
|
||||
SHELL_LIBS="$SHELL_CORE_LIBS $DBUS_LIBS -lz"
|
11
app-text/evince/files/evince-0.7.1-display-menu.patch
Normal file
11
app-text/evince/files/evince-0.7.1-display-menu.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
diff --exclude-from=/home/dang/.diffrc -up -ruN evince-0.7.1.orig/data/evince.desktop.in.in evince-0.7.1/data/evince.desktop.in.in
|
||||
--- evince-0.7.1.orig/data/evince.desktop.in.in 2007-01-10 11:04:20.000000000 -0500
|
||||
+++ evince-0.7.1/data/evince.desktop.in.in 2007-01-18 17:30:52.000000000 -0500
|
||||
@@ -9,7 +9,6 @@ StartupNotify=true
|
||||
Terminal=false
|
||||
Type=Application
|
||||
Icon=evince
|
||||
-NoDisplay=true
|
||||
X-GNOME-DocPath=
|
||||
X-GNOME-Bugzilla-Bugzilla=GNOME
|
||||
X-GNOME-Bugzilla-Product=evince
|
Loading…
Reference in a new issue