remove old ebuild of googleearth, as a newer one is in the official tree
This commit is contained in:
parent
e8de3090fc
commit
d9715f50d5
3 changed files with 0 additions and 95 deletions
|
@ -1,3 +0,0 @@
|
||||||
AUX mime-magic.patch 572 RMD160 e49ddaf43ca7de3cfabf08754f4f4d21864a3489 SHA1 e6689a0f970cfc677749e1ee3aeeaa3b8f5605fc SHA256 302bfab0aa2edd09a2a83f7040de4dcc09998e822555b85242e2e8cb05fb3a12
|
|
||||||
DIST GoogleEarthLinux.bin 20277797 RMD160 c4be844c52d955c0888380ff340c61bc042a9a76 SHA1 63269b522b507f22cf4fd2d64d7e27616db94195 SHA256 769cb3a71147d1ee78668aa07cd3174238ddd318269a191b67101ef6009b698b
|
|
||||||
EBUILD googleearth-4.3.7204.836.ebuild 2072 RMD160 a493f6e0ee36256cce1e9b0b7e86ac67cf99f7fc SHA1 945bd81827e899a2392717d2d3961770f1753f9e SHA256 47b5cf899f94504aed039e50bbf792818aa053f83d2575942c56e703d0ebde18
|
|
|
@ -1,12 +0,0 @@
|
||||||
--- usr/share/mime/packages/googleearth-mimetypes.xml 2006-07-22 10:13:03.000000000 +0100
|
|
||||||
+++ usr/share/mime/packages/googleearth-mimetypes.xml 2006-07-22 10:41:14.584945382 +0100
|
|
||||||
@@ -2,6 +2,9 @@
|
|
||||||
<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
|
|
||||||
<mime-type type="application/vnd.google-earth.kml+xml">
|
|
||||||
<comment>Keyhole Markup Language data</comment>
|
|
||||||
+ <magic priority="60">
|
|
||||||
+ <match value="<kml xmlns="http://earth.google.com/kml/" type="string" offset="0:64"/>
|
|
||||||
+ </magic>
|
|
||||||
<glob pattern="*.kml"/>
|
|
||||||
</mime-type>
|
|
||||||
|
|
|
@ -1,80 +0,0 @@
|
||||||
# Copyright 1999-2008 Gentoo Foundation
|
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
|
||||||
# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/googleearth-4.2.205.5730.ebuild,v 1.3 2008/05/08 04:46:52 je_fro Exp $
|
|
||||||
|
|
||||||
inherit eutils fdo-mime
|
|
||||||
|
|
||||||
DESCRIPTION="A 3D interface to the planet"
|
|
||||||
HOMEPAGE="http://earth.google.com/"
|
|
||||||
SRC_URI="http://dl.google.com/earth/client/GE4/release_4_3/GoogleEarthLinux.bin"
|
|
||||||
|
|
||||||
LICENSE="googleearth MIT X11 SGI-B-1.1 openssl as-is ZLIB"
|
|
||||||
SLOT="0"
|
|
||||||
KEYWORDS="amd64 x86"
|
|
||||||
RESTRICT="mirror strip"
|
|
||||||
IUSE=""
|
|
||||||
|
|
||||||
RDEPEND="x86? (
|
|
||||||
media-libs/fontconfig
|
|
||||||
media-libs/freetype
|
|
||||||
virtual/opengl
|
|
||||||
x11-libs/libICE
|
|
||||||
x11-libs/libSM
|
|
||||||
x11-libs/libX11
|
|
||||||
x11-libs/libXcursor
|
|
||||||
x11-libs/libXext
|
|
||||||
x11-libs/libXft
|
|
||||||
x11-libs/libXrender )
|
|
||||||
amd64? (
|
|
||||||
app-emulation/emul-linux-x86-xlibs
|
|
||||||
app-emulation/emul-linux-x86-baselibs
|
|
||||||
|| (
|
|
||||||
>=app-emulation/emul-linux-x86-xlibs-7.0
|
|
||||||
x11-drivers/nvidia-drivers
|
|
||||||
<x11-drivers/ati-drivers-8.28.8 ) )
|
|
||||||
media-fonts/ttf-bitstream-vera"
|
|
||||||
|
|
||||||
S="${WORKDIR}"
|
|
||||||
|
|
||||||
src_unpack() {
|
|
||||||
unpack_makeself
|
|
||||||
# make the postinst script only create the files; it's installation
|
|
||||||
# are too complicated and inserting them ourselves is easier than
|
|
||||||
# hacking around it
|
|
||||||
sed -i -e 's:$SETUP_INSTALLPATH/::' \
|
|
||||||
-e 's:$SETUP_INSTALLPATH:1:' \
|
|
||||||
-e "s:^xdg-desktop-icon.*$::" \
|
|
||||||
-e "s:^xdg-desktop-menu.*$::" \
|
|
||||||
-e "s:^xdg-mime.*$::" postinstall.sh
|
|
||||||
}
|
|
||||||
|
|
||||||
src_install() {
|
|
||||||
make_wrapper ${PN} ./${PN} /opt/${PN} . || die "make_wrapper failed"
|
|
||||||
./postinstall.sh
|
|
||||||
insinto /usr/share/mime/packages
|
|
||||||
doins ${PN}-mimetypes.xml
|
|
||||||
domenu Google-${PN}.desktop
|
|
||||||
doicon ${PN}-icon.png
|
|
||||||
dodoc README.linux
|
|
||||||
|
|
||||||
cd bin
|
|
||||||
tar xf "${WORKDIR}"/${PN}-linux-x86.tar
|
|
||||||
exeinto /opt/${PN}
|
|
||||||
doexe *
|
|
||||||
|
|
||||||
cd "${D}"/opt/${PN}
|
|
||||||
tar xf "${WORKDIR}"/${PN}-data.tar
|
|
||||||
|
|
||||||
cd "${D}"
|
|
||||||
# mime magic for gnome by Ed Catmur in bug 141371
|
|
||||||
epatch "${FILESDIR}"/mime-magic.patch
|
|
||||||
|
|
||||||
# make sure we install with correct permissions
|
|
||||||
fowners -R root:root /opt/${PN}
|
|
||||||
fperms -R a-x,a+X /opt/googleearth/{xml,res{,ources}}
|
|
||||||
}
|
|
||||||
|
|
||||||
pkg_postinst() {
|
|
||||||
fdo-mime_desktop_database_update
|
|
||||||
fdo-mime_mime_database_update
|
|
||||||
}
|
|
Loading…
Reference in a new issue