removed ebuiold for deskbar-applet-2.18*
This commit is contained in:
parent
93ba0f217c
commit
dceec2c7c9
3 changed files with 0 additions and 124 deletions
|
@ -1,3 +0,0 @@
|
|||
AUX deskbar-applet-2.15.3-multilib.patch 4033 RMD160 8b4ff5d0bfb27102334d22d36a6011787a736c96 SHA1 6e9e147fb12d6ce1d37fe4801e4d9b357097888a SHA256 e0c7a9d8dd4c85038498d29d6f5c16c36ca1c0e49da17435eeb880e7d79d5649
|
||||
DIST deskbar-applet-2.18.1.tar.bz2 646387 RMD160 c7c0015fd0cfcff0d893313e1b0fc658160646ad SHA1 37c3955e1aecf95b56bd727a1cee4222970e37da SHA256 1f1b4ed0d7cd2948aeca7cae33600397218be0b072f105ca0fb05c52e2f1e278
|
||||
EBUILD deskbar-applet-2.18.1.ebuild 1510 RMD160 135c581982bc9e20414aef128e86da01b33d8135 SHA1 1f90b6c9d9d145f1ffee728393053353984e9583 SHA256 483137b278160b27c5d755079b804b52f89191250a94fd5401328cff9b65ae03
|
|
@ -1,55 +0,0 @@
|
|||
# Copyright 1999-2007 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/gnome-extra/deskbar-applet/deskbar-applet-2.18.1.ebuild,v 1.12 2007/10/13 13:24:27 eva Exp $
|
||||
|
||||
inherit gnome2 eutils autotools python
|
||||
|
||||
DESCRIPTION="An Omnipresent Versatile Search Interface"
|
||||
HOMEPAGE="http://raphael.slinckx.net/deskbar/"
|
||||
|
||||
LICENSE="GPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
|
||||
IUSE="eds spell"
|
||||
|
||||
RDEPEND=">=dev-lang/python-2.4
|
||||
>=x11-libs/gtk+-2.6
|
||||
>=dev-python/pygtk-2.6
|
||||
>=dev-python/gnome-python-2.10
|
||||
>=gnome-base/gnome-desktop-2.10
|
||||
>=dev-python/dbus-python-0.71
|
||||
>=dev-python/gnome-python-desktop-2.14.0
|
||||
>=dev-python/gnome-python-extras-2.14
|
||||
>=gnome-base/gconf-2
|
||||
eds? ( >=gnome-extra/evolution-data-server-1.7.92 )
|
||||
spell? ( >=gnome-extra/gnome-utils-2.16.2 )"
|
||||
DEPEND="${RDEPEND}
|
||||
sys-devel/gettext
|
||||
>=dev-util/intltool-0.35
|
||||
>=sys-devel/autoconf-2.60
|
||||
dev-util/pkgconfig"
|
||||
|
||||
DOCS="AUTHORS ChangeLog NEWS README TODO"
|
||||
|
||||
pkg_setup() {
|
||||
G2CONF="${G2CONF} $(use_enable eds evolution) --exec-prefix=/usr"
|
||||
}
|
||||
|
||||
src_unpack() {
|
||||
gnome2_src_unpack
|
||||
|
||||
# Fix installing libs into pythondir
|
||||
epatch "${FILESDIR}"/${PN}-2.15.3-multilib.patch
|
||||
|
||||
AT_M4DIR="m4" eautoreconf
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
gnome2_pkg_postinst
|
||||
|
||||
ebeep 5
|
||||
ewarn "The dictionary plugin in deskbar-applet uses the dictionary from "
|
||||
ewarn "gnome-utils. If it is not present, the dictionary plugin will "
|
||||
ewarn "fail silently."
|
||||
epause 5
|
||||
}
|
|
@ -1,66 +0,0 @@
|
|||
diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.15.3.orig/deskbar/evolution/Makefile.am deskbar-applet-2.15.3/deskbar/evolution/Makefile.am
|
||||
--- deskbar-applet-2.15.3.orig/deskbar/evolution/Makefile.am 2006-05-22 17:30:21.000000000 -0400
|
||||
+++ deskbar-applet-2.15.3/deskbar/evolution/Makefile.am 2006-06-14 13:45:10.000000000 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
INCLUDES = $(PYTHON_INCLUDES) $(EVOLUTION_CFLAGS)
|
||||
|
||||
-_evolutiondir = $(pythondir)/deskbar/evolution
|
||||
+_evolutiondir = $(pyexecdir)/deskbar/evolution
|
||||
_evolution_LTLIBRARIES = _evolution.la
|
||||
_evolution_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_evolution
|
||||
_evolution_la_LIBADD = $(EVOLUTION_LIBS)
|
||||
diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.15.3.orig/deskbar/gdmclient/Makefile.am deskbar-applet-2.15.3/deskbar/gdmclient/Makefile.am
|
||||
--- deskbar-applet-2.15.3.orig/deskbar/gdmclient/Makefile.am 2006-05-31 07:36:27.000000000 -0400
|
||||
+++ deskbar-applet-2.15.3/deskbar/gdmclient/Makefile.am 2006-06-14 13:46:02.000000000 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
INCLUDES = $(PYTHON_INCLUDES) $(DESKBAR_CFLAGS)
|
||||
|
||||
-_gdmclientdir = $(pythondir)/deskbar/gdmclient
|
||||
+_gdmclientdir = $(pyexecdir)/deskbar/gdmclient
|
||||
_gdmclient_LTLIBRARIES = _gdmclient.la
|
||||
_gdmclient_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_gdmclient
|
||||
_gdmclient_la_LIBADD = $(DESKBAR_LIBS)
|
||||
diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.15.3.orig/deskbar/gnomedesktop/Makefile.am deskbar-applet-2.15.3/deskbar/gnomedesktop/Makefile.am
|
||||
--- deskbar-applet-2.15.3.orig/deskbar/gnomedesktop/Makefile.am 2006-05-22 17:30:21.000000000 -0400
|
||||
+++ deskbar-applet-2.15.3/deskbar/gnomedesktop/Makefile.am 2006-06-14 13:45:10.000000000 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
INCLUDES = $(PYTHON_INCLUDES) $(DESKBAR_CFLAGS)
|
||||
|
||||
-_gnomedesktopdir = $(pythondir)/deskbar/gnomedesktop
|
||||
+_gnomedesktopdir = $(pyexecdir)/deskbar/gnomedesktop
|
||||
_gnomedesktop_LTLIBRARIES = _gnomedesktop.la
|
||||
_gnomedesktop_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_gnomedesktop
|
||||
_gnomedesktop_la_LIBADD = $(DESKBAR_LIBS)
|
||||
diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.15.3.orig/deskbar/iconentry/Makefile.am deskbar-applet-2.15.3/deskbar/iconentry/Makefile.am
|
||||
--- deskbar-applet-2.15.3.orig/deskbar/iconentry/Makefile.am 2006-05-22 17:30:22.000000000 -0400
|
||||
+++ deskbar-applet-2.15.3/deskbar/iconentry/Makefile.am 2006-06-14 13:45:10.000000000 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
INCLUDES = $(PYTHON_INCLUDES) $(DESKBAR_CFLAGS)
|
||||
|
||||
-_iconentrydir = $(pythondir)/deskbar/iconentry
|
||||
+_iconentrydir = $(pyexecdir)/deskbar/iconentry
|
||||
_iconentry_LTLIBRARIES = _iconentry.la
|
||||
_iconentry_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_iconentry
|
||||
_iconentry_la_LIBADD = $(DESKBAR_LIBS)
|
||||
diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.15.3.orig/deskbar/keybinder/Makefile.am deskbar-applet-2.15.3/deskbar/keybinder/Makefile.am
|
||||
--- deskbar-applet-2.15.3.orig/deskbar/keybinder/Makefile.am 2006-05-22 17:30:22.000000000 -0400
|
||||
+++ deskbar-applet-2.15.3/deskbar/keybinder/Makefile.am 2006-06-14 13:45:10.000000000 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
INCLUDES = $(PYTHON_INCLUDES) $(DESKBAR_CFLAGS)
|
||||
|
||||
-_keybinderdir = $(pythondir)/deskbar/keybinder
|
||||
+_keybinderdir = $(pyexecdir)/deskbar/keybinder
|
||||
_keybinder_LTLIBRARIES = _keybinder.la
|
||||
_keybinder_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_keybinder
|
||||
_keybinder_la_LIBADD = $(DESKBAR_LIBS)
|
||||
diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.15.3.orig/deskbar/osutils/Makefile.am deskbar-applet-2.15.3/deskbar/osutils/Makefile.am
|
||||
--- deskbar-applet-2.15.3.orig/deskbar/osutils/Makefile.am 2006-05-22 17:30:22.000000000 -0400
|
||||
+++ deskbar-applet-2.15.3/deskbar/osutils/Makefile.am 2006-06-14 13:45:10.000000000 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
INCLUDES = $(PYTHON_INCLUDES) $(DESKBAR_CFLAGS)
|
||||
|
||||
-_osutilsdir = $(pythondir)/deskbar/osutils
|
||||
+_osutilsdir = $(pyexecdir)/deskbar/osutils
|
||||
_osutils_LTLIBRARIES = _osutils.la
|
||||
_osutils_la_LDFLAGS = -module -avoid-version init_osutils
|
||||
_osutils_la_LIBADD = $(DESKBAR_LIBS)
|
Loading…
Reference in a new issue