removed ebuild for mu-conference, as i don't need it anymore
This commit is contained in:
parent
d2c5470fce
commit
f0a79a10a8
9 changed files with 0 additions and 278 deletions
|
@ -1,9 +0,0 @@
|
|||
AUX README.Gentoo 1483 RMD160 f3f059fc9789e4b162485f72f43dd788418cdb24 SHA1 6131ff6d57cff11ae1d875bf983d71decbf74ebc SHA256 36efdb71c2d68941fe1d26c5989064a9ed18d91e6bfd83ae884e9088a17b6159
|
||||
AUX mu-conference-0.7.init 410 RMD160 56d96e68d1715beecf6e695f8a1d9d484291cd65 SHA1 8e5c152ba6afd1138ecc208f0de96232c28e3e1a SHA256 ab08f29e14514d3705c83a7149629b2081140d7ef2f27ff49e4ca58c94742c07
|
||||
AUX mu-conference-conf.d 435 RMD160 e195766105473e83969bd9ed9de4e37dacc19baa SHA1 b77c8b806a882df5a58c26804848a9a927aae77c SHA256 d1c13df4fe3be4cb15b830f4b5935fc51d0a09e827e99225ae189fafdbc7e741
|
||||
AUX mu-conference-makefile.patch 430 RMD160 ca5d8b9b8a12616c1b35dae285367e99d982e9aa SHA1 d7ad1db101b9b014e33511be7c84e697a6052841 SHA256 58e36385215a1da9278a914939e807c5379b0960cae645ac8f288e9d29dd93d3
|
||||
AUX muc-transport.init 529 RMD160 b9b4f46012ee5e83a4772666432ec884ce14361c SHA1 d70825a0c1397dc2877f633d496b1fbcc74be6e1 SHA256 d4f772a6c94bc19ea45b3cb6e6a92f9ac26ccddb344112053485fb0db606e9bf
|
||||
AUX muc-transport.init-r2 532 RMD160 8cfa94e0e0510044bddd07bcabcac979d45735e0 SHA1 cd6424c1a2bf8c7a1e636ba0cb9a7ff482bedb15 SHA256 359b28c8218c5f26154d2ca051031c1d37cfb36e55de8a3d71f67d66893bdab2
|
||||
AUX muctrans.xml 908 RMD160 b2ddb59e7a85651b2478b717cf5182d326f2d857 SHA1 581cdb5badb9652d99b9717b034e2a4afa534599 SHA256 66b653cc18a1738520cd012e2d71079724a34d1f84e4c3aad5e9b84d485fc6aa
|
||||
DIST mu-conference_0.7.tar.gz 112381 RMD160 82a02434414ec3eb925959401b5c847912088e6b SHA1 eb8e21f708587a02042f425a814db6fff6e0ba7e SHA256 914d7e5cf45c50e3eaae77d03d895211d332f85469f4a70adaf7209917d27a35
|
||||
EBUILD mu-conference-0.7-r1.ebuild 2168 RMD160 0f51683f79bed8531104ad30c91b08d8ef2cd7f8 SHA1 6662b47860e1ce3800e5531bf661db019c45c6b4 SHA256 c70aa5b430ac3efaad6b82e340f6e3cec65468eaf22ad4baef4b831c1c24fb43
|
|
@ -1,40 +0,0 @@
|
|||
This is a small help to get you started with the MSN Jabberd transport in
|
||||
Gentoo.
|
||||
|
||||
Edit /etc/jabber/muctrans.xml . This is the config file for MU-Conference.
|
||||
There change all references to localhost with the FQDN (Fully Qualified Domain
|
||||
Name) for your server.
|
||||
|
||||
In the msnlinker section enter the IP of your main jabber server (normally
|
||||
127.0.0.1) and choose a port and secret (secret is the password the MSN
|
||||
transport will use to connect to the main jabber server).
|
||||
|
||||
Now back to the multiple.xml to tell your main jabber server to listen to
|
||||
connections from the MU transport.
|
||||
Search for "<vcard2jud/>" and after that, and before the </jsm> add:
|
||||
|
||||
<browse>
|
||||
<item category="conference" type="public" jid="conference.localhost" name="Public Conferencing" version="0.6.0">
|
||||
<ns>http://jabber.org/protocol/muc</ns>
|
||||
</item>
|
||||
</browse>
|
||||
|
||||
Again here change localhost for your FQDN.
|
||||
|
||||
Scrool down to the bottom of the file, and just before the </jabber> add:
|
||||
|
||||
<service id="muclinker">
|
||||
<host>conference.localhost</host>
|
||||
<accept>
|
||||
<ip>127.0.0.1</ip>
|
||||
<port>31518</port>
|
||||
<secret>mymucsecret</secret>
|
||||
</accept>
|
||||
</service>
|
||||
(By know you know you have to change localhost for you FQDN).
|
||||
One very importante thing: even if it is the same machine the name's for the
|
||||
various services must be diferent, that means that there must be valid aliases
|
||||
for conference.FQDN .
|
||||
|
||||
If you need help with configuration you can try the Jabber Admin Mailling list:
|
||||
http://mailman.jabber.org/listinfo/jadmin
|
|
@ -1,25 +0,0 @@
|
|||
#!/sbin/runscript
|
||||
|
||||
depend() {
|
||||
need net
|
||||
use jabber-server
|
||||
}
|
||||
|
||||
start() {
|
||||
ebegin "Starting MUC Jabber Transport"
|
||||
start-stop-daemon \
|
||||
--background \
|
||||
--start \
|
||||
--chuid jabber:jabber \
|
||||
--exec /usr/bin/mu-conference \
|
||||
-- -c /etc/jabber/mu-conference.xml
|
||||
eend $?
|
||||
}
|
||||
|
||||
stop() {
|
||||
ebegin "Stoping MUC Jabber Transport"
|
||||
start-stop-daemon \
|
||||
--stop \
|
||||
--pidfile /var/run/jabber/mu-conference.pid
|
||||
eend $?
|
||||
}
|
|
@ -1,9 +0,0 @@
|
|||
# Copyright 1999-2004 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License, v2 or later
|
||||
# $Header: /var/cvsroot/gentoo-x86/net-im/mu-conference/files/mu-conference-conf.d,v 1.4 2004/07/08 17:35:01 humpback Exp $
|
||||
|
||||
CONFIG="/etc/jabber/muctrans.xml"
|
||||
|
||||
#Need to find a way to fix the "double" expansion
|
||||
#PIDFILE= grep pid ${CONFIG} | sed -e 's/<[^>]*>//g' | sed s/' '//g
|
||||
PIDFILE="/var/log/jabber/muctrans.pid"
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile 2003-11-15 04:19:44.000000000 +0000
|
||||
+++ Makefile.new 2004-01-10 02:20:28.753368424 +0000
|
||||
@@ -1,6 +1,6 @@
|
||||
-include ../../platform-settings
|
||||
+include /usr/lib/jabberd/platform-settings
|
||||
|
||||
-CFLAGS:=$(CFLAGS) -I../../jabberd -I../include `pkg-config --cflags glib-2.0`
|
||||
+CFLAGS:=$(CFLAGS) -I/usr/include/jabberd -I../include `pkg-config --cflags glib-2.0`
|
||||
LIBS:=$(LIBS) `pkg-config --libs glib-2.0`
|
||||
|
||||
# Debug/Experimental
|
|
@ -1,26 +0,0 @@
|
|||
#!/sbin/runscript
|
||||
|
||||
depend() {
|
||||
need net
|
||||
use jabber-server
|
||||
}
|
||||
|
||||
start() {
|
||||
ebegin "Starting MUC Jabber Transport"
|
||||
jabberd -B -c /etc/jabber/muctrans.xml -H /var/spool/jabber >/dev/null 2>&1
|
||||
eend $?
|
||||
}
|
||||
|
||||
stop() {
|
||||
ebegin "Stoping MUC Jabber Transport"
|
||||
if [ -f /var/log/jabber/muctrans.pid ]; then
|
||||
kill `cat /var/log/jabber/muctrans.pid`
|
||||
fi
|
||||
sleep 2
|
||||
if [ -f /var/log/jabber/muctrans.pid ]; then
|
||||
kill -9 `cat /var/log/jabber/muctrans.pid`
|
||||
rm -f /var/log/jabber/muctrans.pid
|
||||
fi
|
||||
rm -f /var/log/jabber/muctrans.pid
|
||||
eend $?
|
||||
}
|
|
@ -1,33 +0,0 @@
|
|||
#!/sbin/runscript
|
||||
|
||||
depend() {
|
||||
need net
|
||||
use jabber-server
|
||||
}
|
||||
|
||||
start() {
|
||||
ebegin "Starting MUC Jabber Transport"
|
||||
if [ -f ${PIDFILE} ]; then
|
||||
if [ -z $(ps ax | grep `cat ${PIDFILE}` | grep -v grep ) ]
|
||||
then
|
||||
rm -f ${PIDFILE}
|
||||
fi
|
||||
fi
|
||||
|
||||
jabberd -B -c ${CONFIG} -H /var/spool/jabber >/dev/null 2>&1
|
||||
eend $?
|
||||
}
|
||||
|
||||
stop() {
|
||||
ebegin "Stoping MUC Jabber Transport"
|
||||
if [ -f ${PIDFILE} ]; then
|
||||
kill `cat ${PIDFILE}`
|
||||
fi
|
||||
sleep 2
|
||||
if [ -f ${PIDFILE} ]; then
|
||||
kill -9 `cat ${PIDFILE}`
|
||||
rm -f ${PIDFILE}
|
||||
fi
|
||||
rm -f ${PIDFILE}
|
||||
eend $?
|
||||
}
|
|
@ -1,37 +0,0 @@
|
|||
<jabber>
|
||||
|
||||
<service id="muclinker">
|
||||
<uplink/>
|
||||
<connect>
|
||||
<ip>127.0.0.1</ip>
|
||||
<port>31518</port>
|
||||
<secret>mymucsecret</secret>
|
||||
</connect>
|
||||
</service>
|
||||
|
||||
<service id="conference.localhost">
|
||||
<load>
|
||||
<conference>/usr/lib/jabberd/mu-conference.so</conference>
|
||||
</load>
|
||||
<conference xmlns="jabber:config:conference">
|
||||
<public/>
|
||||
<vCard>
|
||||
<FN>Public Chatrooms</FN>
|
||||
<DESC>This service is for public chatrooms.</DESC>
|
||||
<URL>http://conference.localhost/logs/</URL>
|
||||
</vCard>
|
||||
<history>20</history>
|
||||
<logdir>/var/log/jabber/conference/</logdir>
|
||||
<sadmin>admin@localhost</sadmin>
|
||||
<notice>
|
||||
<join>has joined this session</join>
|
||||
<leave>has left</leave>
|
||||
<rename>is now known as</rename>
|
||||
</notice>
|
||||
</conference>
|
||||
</service>
|
||||
|
||||
<pidfile>/var/log/jabber/muctrans.pid</pidfile>
|
||||
|
||||
</jabber>
|
||||
|
|
@ -1,88 +0,0 @@
|
|||
# Copyright 1999-2007 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: $
|
||||
|
||||
inherit eutils
|
||||
|
||||
DESCRIPTION="Multi-User Chat for jabberd"
|
||||
HOMEPAGE="https://gna.org/projects/mu-conference/"
|
||||
SRC_URI="http://download.gna.org/mu-conference/${PN}_${PV}.tar.gz"
|
||||
|
||||
LICENSE="GPL-2"
|
||||
KEYWORDS="~x86 ~amd64 ~sparc"
|
||||
SLOT="0"
|
||||
|
||||
DEPEND="dev-libs/expat
|
||||
>=dev-libs/glib-2
|
||||
net-dns/libidn
|
||||
|| (net-im/jabberd net-im/jabberd2)
|
||||
mysql? ( virtual/mysql )"
|
||||
|
||||
IUSE="mysql"
|
||||
|
||||
|
||||
S="${WORKDIR}/${PN}_${PV}"
|
||||
|
||||
src_unpack() {
|
||||
unpack ${A}
|
||||
cd ${S}
|
||||
|
||||
# Fix missing header in src/conference_user.c in order to
|
||||
# make emerge happy and avoid QA notice.
|
||||
sed -i "/conference.h/ i #define _XOPEN_SOURCE" src/conference_user.c
|
||||
|
||||
if use mysql; then
|
||||
sed -i '/^CFLAGS/ a CFLAGS:=$(CFLAGS) -DHAVE_MYSQL' src/Makefile
|
||||
else
|
||||
# Makefile is broken. Should not always link against mysql
|
||||
sed -i 's/`mysql_config --libs`//' src/Makefile
|
||||
fi
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
emake || die
|
||||
}
|
||||
|
||||
src_install() {
|
||||
exeinto /usr/bin
|
||||
doexe src/mu-conference
|
||||
fowners jabber:jabber /usr/bin/mu-conference
|
||||
fperms 750 /usr/bin/mu-conference
|
||||
|
||||
newinitd ${FILESDIR}/${P}.init mu-conference
|
||||
|
||||
dodoc ChangeLog FAQ mu-conference.sql README
|
||||
docinto scripts
|
||||
dodoc scripts/*
|
||||
|
||||
for i in log spool; do
|
||||
dodir /var/${i}/jabber/mu-conference
|
||||
keepdir /var/${i}/jabber/mu-conference
|
||||
fowners jabber:jabber /var/${i}/jabber/mu-conference
|
||||
fperms 770 /var/${i}/jabber/mu-conference
|
||||
done
|
||||
|
||||
insinto /etc/jabber
|
||||
newins muc-default.xml mu-conference.xml
|
||||
doins style.css
|
||||
|
||||
cd "${D}/etc/jabber/"
|
||||
sed -i \
|
||||
-e 's,./spool/chat.localhost,/var/spool/jabber/mu-conference,g' \
|
||||
-e 's,./syslogs,/var/log/jabber,g' \
|
||||
-e 's,./logs,/var/log/jabber/mu-conference,g' \
|
||||
-e 's,./mu-conference.pid,/var/run/jabber/mu-conference.pid,g' \
|
||||
-e "s,../style.css,/etc/jabber/style.css,g" \
|
||||
-e "s,7009,5347,g" \
|
||||
mu-conference.xml || die "sed failed"
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
elog
|
||||
elog "For jabberd-2 connection:"
|
||||
elog "1. Make sure that the ip and port in /etc/jabber/mu-conference.xml"
|
||||
elog " match the address of your jabberd router."
|
||||
elog "2. Set a common secret in mu-conference.xml and router.xml"
|
||||
elog
|
||||
}
|
||||
|
Loading…
Reference in a new issue