gentoo-overlay/dev-python/geoip2/geoip2-4.8.0.ebuild
Manuel Friedli 7f08e93af8
All checks were successful
continuous-integration/drone/push Build is passing
continuous-integration/drone/pr Build is passing
Big update: some new version, some cleanup, LOTS of manifest regeneration.
2024-10-27 02:06:35 +02:00

22 lines
504 B
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..12} )
inherit distutils-r1 pypi
DESCRIPTION="MaxMind GeoIP2 API"
HOMEPAGE="https://github.com/maxmind/GeoIP2-python"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="
>=dev-python/requests-2.24.0[${PYTHON_USEDEP}]
>=dev-python/maxminddb-2.0.0[${PYTHON_USEDEP}]
"