gentoo-overlay/dev-vcs/gitlab-git-http-server/files/fix-Makefile-0.3.0.patch

17 lines
543 B
Diff

diff --git a/Makefile b/Makefile
index f6456e1..55af079 100644
--- a/Makefile
+++ b/Makefile
@@ -1,8 +1,8 @@
-PREFIX=/usr/local
-VERSION=$(shell git describe)-$(shell date -u +%Y%m%d.%H%M%S)
+PREFIX=${DESTDIR}/usr
+VERSION=0.3.0-$(shell date -u +%Y%m%d.%H%M%S)
gitlab-git-http-server: main.go githandler.go
- go build -ldflags "-X main.Version ${VERSION}" -o gitlab-git-http-server
+ go build -ldflags "-X main.Version=${VERSION}" -o gitlab-git-http-server
install: gitlab-git-http-server
install gitlab-git-http-server ${PREFIX}/bin/