gentoo-overlay/dev-vcs/gitlab-workhorse/files/fix-Makefile-0.7.11.patch
Manuel Friedli 266e472da1 dev-vcs/gitlab-workhorse:
added ebuild for gitlab-workhorse-0.7.11

Package-Manager: portage-2.2.28
2016-08-29 08:43:21 +02:00

13 lines
380 B
Diff

diff --git a/Makefile b/Makefile
index 5ac82e5..63a967b 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
-PREFIX=/usr/local
-VERSION=$(shell git describe)-$(shell date -u +%Y%m%d.%H%M%S)
+PREFIX=${DESTDIR}/usr
+VERSION=v0.7.11-$(shell date -u +%Y%m%d.%H%M%S)
BUILD_DIR = $(shell pwd)
export GOPATH=${BUILD_DIR}/_build
GOBUILD=go build -ldflags "-X main.Version=${VERSION}"