gentoo-overlay/dev-vcs/gitlab-workhorse/files/fix-Makefile-0.7.8.patch
Manuel Friedli 33f5f3510e dev-vcs/gitlab-workhorse:
added ebuild for version 0.7.8

Package-Manager: portage-2.2.28
2016-07-12 00:10:40 +02:00

13 lines
397 B
Diff

diff --git a/Makefile b/Makefile
index 9b3146d..b3c0630 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
-PREFIX=/usr/local
-VERSION=$(shell git describe)-$(shell date -u +%Y%m%d.%H%M%S)
+PREFIX=${DESTDIR}/usr
+VERSION=v0.7.8-$(shell date -u +%Y%m%d.%H%M%S)
export GOPATH=$(shell pwd)/_build
GOBUILD=go build -ldflags "-X main.Version=${VERSION}"
PKG=gitlab.com/gitlab-org/gitlab-workhorse