gentoo-overlay/dev-vcs/gitlab-workhorse/files/fix-Makefile-0.7.10.patch
Manuel Friedli 4bce05ffbc dev-vcs/gitlab-workhorse:
added ebuild for gitlab-workhorse-0.7.10. this is a dependeny of gitlab-ce-9999

Package-Manager: portage-2.2.28
2016-08-23 01:56:26 +02:00

13 lines
380 B
Diff

diff --git a/Makefile b/Makefile
index 5ac82e5..63a967b 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
-PREFIX=/usr/local
-VERSION=$(shell git describe)-$(shell date -u +%Y%m%d.%H%M%S)
+PREFIX=${DESTDIR}/usr
+VERSION=v0.7.10-$(shell date -u +%Y%m%d.%H%M%S)
BUILD_DIR = $(shell pwd)
export GOPATH=${BUILD_DIR}/_build
GOBUILD=go build -ldflags "-X main.Version=${VERSION}"