18 lines
744 B
Diff
18 lines
744 B
Diff
diff --git a/src/gitlab.com/gitlab-org/gitlab-pages/Makefile b/src/gitlab.com/gitlab-org/gitlab-pages/Makefile
|
|
index 2c1b8e1..4c6feb0 100644
|
|
--- a/src/gitlab.com/gitlab-org/gitlab-pages/Makefile
|
|
+++ b/src/gitlab.com/gitlab-org/gitlab-pages/Makefile
|
|
@@ -1,12 +1,6 @@
|
|
-REVISION := $(shell git rev-parse --short HEAD || echo unknown)
|
|
-LAST_TAG := $(shell git describe --tags --abbrev=0)
|
|
-COMMITS := $(shell echo `git log --oneline $(LAST_TAG)..HEAD | wc -l`)
|
|
+REVISION := @@REVISION@@
|
|
VERSION := $(shell cat VERSION)
|
|
|
|
-ifneq (v$(VERSION),$(LAST_TAG))
|
|
- VERSION := $(shell echo $(VERSION)~beta.$(COMMITS).g$(REVISION))
|
|
-endif
|
|
-
|
|
GO_LDFLAGS ?= -X main.VERSION=$(VERSION) -X main.REVISION=$(REVISION)
|
|
GO_FILES ?= $(shell find . -name '*.go')
|
|
|