added ebuilds for ptlib and latest opal
This commit is contained in:
parent
cc9c234eb2
commit
8951e57cf2
5 changed files with 198 additions and 0 deletions
4
dev-libs/ptlib/Manifest
Normal file
4
dev-libs/ptlib/Manifest
Normal file
|
@ -0,0 +1,4 @@
|
||||||
|
AUX ptlib-asm.patch 561 RMD160 3825ccdf533c614d6ed5ec2462e0b4308d72225b SHA1 3d9547f09baec55729bf8c8465064a67226b4bec SHA256 f97c433c846f9280c8f2e30b2ca3c618059bc4b809e892bb1ad7eba900b5e670
|
||||||
|
DIST ptlib-2.4.2-htmldoc.tar.gz 3041603 RMD160 fbbfaee06a432f36bb461dd9eaf6c9f1a05de7be SHA1 1edc0a7ddda1654187aa746a78131853d9997704 SHA256 d1e90b9c225ccc9dd753ce308cabb34d4de28c7d70b22bf3bff1cf65df695fb9
|
||||||
|
DIST ptlib-2.4.2.tar.bz2 3004289 RMD160 110c53c4dc6f1144a5b11bb63b0f114fdeee2fc9 SHA1 d4fb343006fc108ca7cc0431a14cf4c4ea7233d3 SHA256 27aa99fbb677e08a1795f171517a2bdf73d84e5114f20f621c290a78f99d994b
|
||||||
|
EBUILD ptlib-2.4.2.ebuild 2401 RMD160 13b0195090a422bc50b433b3fa0644c3156ef45f SHA1 1c91fc08772073a4f433a89d66f6e6b0a1b4f19c SHA256 228b93340773046c7cb054c26bdba137329ea047ed53dee843ffd7e14997c2c7
|
15
dev-libs/ptlib/files/ptlib-asm.patch
Normal file
15
dev-libs/ptlib/files/ptlib-asm.patch
Normal file
|
@ -0,0 +1,15 @@
|
||||||
|
--- src/ptlib/common/jidctflt.cxx.orig 2008-09-24 09:13:06.000000000 -0400
|
||||||
|
+++ src/ptlib/common/jidctflt.cxx 2008-09-24 09:11:49.000000000 -0400
|
||||||
|
@@ -110,10 +110,10 @@
|
||||||
|
"\tsar %2,%1\n"
|
||||||
|
"\tsub $-128,%1\n"
|
||||||
|
"\tcmovl %5,%1\n" /* Use the sub to compare to 0 */
|
||||||
|
- "\tcmpl %4,%1\n"
|
||||||
|
+ "\tcmp %4,%1\n"
|
||||||
|
"\tcmovg %4,%1\n"
|
||||||
|
: "=r"(x)
|
||||||
|
- : "0"(x), "Ir"(shift), "ir"(1UL<<(shift-1)), "r" (0xff), "r" (0)
|
||||||
|
+ : "0"((unsigned long)x), "c"((char)shift), "ir"(1UL<<(shift-1)), "r" (0xffUL), "r" (0UL)
|
||||||
|
);
|
||||||
|
return x;
|
||||||
|
}
|
102
dev-libs/ptlib/ptlib-2.4.2.ebuild
Normal file
102
dev-libs/ptlib/ptlib-2.4.2.ebuild
Normal file
|
@ -0,0 +1,102 @@
|
||||||
|
# Copyright 1999-2008 Gentoo Foundation
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
# $Header: $
|
||||||
|
|
||||||
|
EAPI="1"
|
||||||
|
|
||||||
|
inherit eutils
|
||||||
|
|
||||||
|
DESCRIPTION="Network focused portable C++ class library providing high level functions"
|
||||||
|
HOMEPAGE="http://www.opalvoip.org/"
|
||||||
|
SRC_URI="mirror://sourceforge/opalvoip/${P}.tar.bz2
|
||||||
|
doc? ( mirror://sourceforge/opalvoip/${P}-htmldoc.tar.gz )"
|
||||||
|
|
||||||
|
LICENSE="MPL-1.0"
|
||||||
|
SLOT="0"
|
||||||
|
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
|
||||||
|
IUSE="alsa bsdvideo debug doc esd ieee1394 ipv6 ldap minimal noaudio novideo oss
|
||||||
|
sasl sdl ssl sunaudio v4l v4l2 xml"
|
||||||
|
|
||||||
|
RDEPEND="alsa? ( media-libs/alsa-lib )
|
||||||
|
esd? ( media-sound/esound )
|
||||||
|
ieee1394? ( media-libs/libdv
|
||||||
|
sys-libs/libavc1394
|
||||||
|
media-libs/libdc1394:1 )
|
||||||
|
ldap? ( net-nds/openldap )
|
||||||
|
sasl? ( dev-libs/cyrus-sasl:2 )
|
||||||
|
sdl? ( media-libs/libsdl )
|
||||||
|
ssl? ( dev-libs/openssl )
|
||||||
|
xml? ( dev-libs/expat )"
|
||||||
|
DEPEND="${RDEPEND}
|
||||||
|
sys-devel/bison
|
||||||
|
sys-devel/flex
|
||||||
|
v4l? ( sys-kernel/linux-headers )
|
||||||
|
v4l2? ( sys-kernel/linux-headers )
|
||||||
|
!dev-libs/pwlib"
|
||||||
|
|
||||||
|
src_unpack() {
|
||||||
|
unpack ${A}
|
||||||
|
cd "${S}"
|
||||||
|
|
||||||
|
# move files from ${P}-htmldoc.tar.gz
|
||||||
|
use doc && mv ../html .
|
||||||
|
|
||||||
|
# this patch fixes bugs: #145424 and #140358
|
||||||
|
epatch "${FILESDIR}"/${PN}-asm.patch
|
||||||
|
}
|
||||||
|
|
||||||
|
src_compile() {
|
||||||
|
local myconf=""
|
||||||
|
local makeopts=""
|
||||||
|
|
||||||
|
use noaudio && myconf="${myconf} --disable-audio"
|
||||||
|
use novideo && myconf="${myconf} --disable-video"
|
||||||
|
|
||||||
|
econf \
|
||||||
|
${myconf} \
|
||||||
|
$(use_enable alsa) \
|
||||||
|
$(use_enable bsdvideo) \
|
||||||
|
$(use_enable debug exceptions) \
|
||||||
|
$(use_enable debug memcheck) \
|
||||||
|
$(use_enable esd) \
|
||||||
|
$(use_enable ieee1394 avc) \
|
||||||
|
$(use_enable ieee1394 dc) \
|
||||||
|
$(use_enable ipv6) \
|
||||||
|
$(use_enable ldap openldap) \
|
||||||
|
$(use_enable minimal minsize) \
|
||||||
|
$(use_enable oss) \
|
||||||
|
$(use_enable sasl) \
|
||||||
|
$(use_enable sdl) \
|
||||||
|
$(use_enable ssl openssl) \
|
||||||
|
$(use_enable sunaudio) \
|
||||||
|
$(use_enable v4l) \
|
||||||
|
$(use_enable v4l2) \
|
||||||
|
$(use_enable xml expat) \
|
||||||
|
--enable-plugins \
|
||||||
|
|| die "econf failed"
|
||||||
|
|
||||||
|
if use debug; then
|
||||||
|
makeopts="${makeopts} DEBUG=1 debug"
|
||||||
|
fi
|
||||||
|
|
||||||
|
emake ${makeopts} || die "emake failed"
|
||||||
|
}
|
||||||
|
|
||||||
|
src_install() {
|
||||||
|
local makeopts
|
||||||
|
|
||||||
|
makeopts="PREFIX=/usr DESTDIR=\"${D}\""
|
||||||
|
|
||||||
|
if use debug; then
|
||||||
|
makeopts="${makeopts} DEBUG=1"
|
||||||
|
fi
|
||||||
|
|
||||||
|
emake ${makeopts} install || die "emake install failed"
|
||||||
|
|
||||||
|
if use doc; then
|
||||||
|
dohtml -r html/* || die "documentation installation failed"
|
||||||
|
fi
|
||||||
|
|
||||||
|
dodoc ReadMe.txt ReadMe_QOS.txt History.txt || die "documentation
|
||||||
|
installation failed"
|
||||||
|
}
|
3
net-libs/opal/Manifest
Normal file
3
net-libs/opal/Manifest
Normal file
|
@ -0,0 +1,3 @@
|
||||||
|
DIST opal-3.4.2-htmldoc.tar.gz 7340648 RMD160 00406c37cc9ed8ebb1accf130bc77740db73a9d6 SHA1 25c569d6cec7fd92e33d6d23e42aca1e523489bf SHA256 78b15ba91badf2783541f634bdea437d1ceb39615be1c657c42939f2b3ac7d8e
|
||||||
|
DIST opal-3.4.2.tar.bz2 8260545 RMD160 9c62db97e8cf5d3add9e2c7aa7cecf9953dc0f39 SHA1 53a2adfccd4fa0f2cffece94690cea29c0a38a47 SHA256 fd598df06d472fbedd887f9c44d6a8fe1984730a0a72408352de2d7172f5ab3b
|
||||||
|
EBUILD opal-3.4.2.ebuild 1761 RMD160 56227d4783507070fe021f5326be40988c562be0 SHA1 604cff5230066cf117db6eef0d134f58c6e47c11 SHA256 000aebe683d38bfc45f11ea9f8724f32c9f0f7f29a5464d3f247bf4ab33029db
|
74
net-libs/opal/opal-3.4.2.ebuild
Normal file
74
net-libs/opal/opal-3.4.2.ebuild
Normal file
|
@ -0,0 +1,74 @@
|
||||||
|
# Copyright 1999-2008 Gentoo Foundation
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
# $Header: $
|
||||||
|
|
||||||
|
inherit eutils flag-o-matic
|
||||||
|
|
||||||
|
DESCRIPTION="C++ class library normalising numerous telephony protocols"
|
||||||
|
HOMEPAGE="http://www.opalvoip.org/"
|
||||||
|
SRC_URI="mirror://sourceforge/opalvoip/${P}.tar.bz2
|
||||||
|
doc? ( mirror://sourceforge/opalvoip/${P}-htmldoc.tar.gz )"
|
||||||
|
|
||||||
|
LICENSE="MPL-1.0"
|
||||||
|
SLOT="0"
|
||||||
|
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
|
||||||
|
IUSE="debug doc java"
|
||||||
|
|
||||||
|
RDEPEND=">=dev-libs/ptlib-2.0.0
|
||||||
|
>=media-video/ffmpeg-0.4.7
|
||||||
|
media-libs/speex
|
||||||
|
java? ( virtual/jdk )"
|
||||||
|
|
||||||
|
pkg_setup() {
|
||||||
|
if use debug && ! built_with_use dev-libs/ptlib debug; then
|
||||||
|
eerror "You need to build dev-libs/ptlib with USE=debug enabled."
|
||||||
|
die "dev-libs/ptlib has to be built with USE=debug"
|
||||||
|
fi
|
||||||
|
|
||||||
|
if ! use debug && built_with_use dev-libs/ptlib debug; then
|
||||||
|
eerror "You need to build dev-libs/ptlib without USE=debug."
|
||||||
|
die "dev-libs/ptlib has not to be built with USE=debug"
|
||||||
|
fi
|
||||||
|
}
|
||||||
|
|
||||||
|
src_unpack() {
|
||||||
|
unpack ${A}
|
||||||
|
cd "${S}"
|
||||||
|
|
||||||
|
# move files from ${P}-htmldoc.tar.gz
|
||||||
|
use doc && mv ../html .
|
||||||
|
|
||||||
|
epatch "${FILESDIR}"/${PN}-lpcini.patch
|
||||||
|
}
|
||||||
|
|
||||||
|
src_compile() {
|
||||||
|
local makeopts
|
||||||
|
|
||||||
|
filter-ldflags -Wl,--as-needed --as-needed
|
||||||
|
|
||||||
|
# zrtp doesn't depend on net-libs/libzrtpcpp but on libzrtp from
|
||||||
|
# http://zfoneproject.com/ that is not in portage
|
||||||
|
econf \
|
||||||
|
$(use_enable debug) \
|
||||||
|
$(use_enable java) \
|
||||||
|
--enable-plugins \
|
||||||
|
--disable-localspeex \
|
||||||
|
--disable-zrtp \
|
||||||
|
|| die "econf failed"
|
||||||
|
|
||||||
|
if use debug; then
|
||||||
|
makeopts="debug"
|
||||||
|
else
|
||||||
|
makeopts="opt"
|
||||||
|
fi
|
||||||
|
|
||||||
|
emake ${makeopts} || die "emake failed"
|
||||||
|
}
|
||||||
|
|
||||||
|
src_install() {
|
||||||
|
emake PREFIX=/usr DESTDIR="${D}" install || die "emake install failed"
|
||||||
|
|
||||||
|
if use doc; then
|
||||||
|
dohtml -r html/* docs/* || die "documentation installation failed"
|
||||||
|
fi
|
||||||
|
}
|
Loading…
Reference in a new issue